PRC Lite and NWNCX


#1

Hi everyone. I’ve been trying to make PRC lite to work. PRC lite mentions it needs Community patch 1.72 and I’ve installed that. The problem is I dont know what exactly NWNCX is, which PRC lite mentions is also a prerequisite. I tried installing this one:

I placed all the dlls on my main installation folder then use the loader.exe it provided to launch the game. The PRC 1.72 installer included a nwncx_patch.dll file so I assume I got that covered too.

Problem is I still can’t make PRC lite to work properly. I’m assuming I’m doing something wrong with NWNCX because only the Champion of Bane class works which is the only one with no minimum spell level prereq, and the PRC lite page mentions NWNCX_Patch is required to fulfill minimum spell level prereq.

All I really want is to make my sorc an archmage. Help please! Thank you.


#2

Assuming you want this for singleplayer then you need NWNCX - http://www.neverwinternights.info/nwncx.htm

I am not distributing the NWNCX within my project as it would be bad etiquette. So you need to download in manually. Then you need to start nwn using NWNCX_Loader.exe and give that admin rights. (Unless you patch the nwmain.exe).

Then it should work. But it is some time I was working on it and I am not sure if this works as override, I assume not…


#3

I’m afraid I’m having the same issue. I know for a fact that I’m using NWNCX and the appropriate plugin, because I also use WodahsEht’s Prestige Spellbook Pack on occasion (I’m actually trying to merge that and your own PRC Lite for my own private use!) and that mod works fine whether I use the Override or Hak version.

No matter what, none of the classes other than Champion of Bane become selectable, even if the character meets the requirements.


#4

I just tested it myself with Diablo - The Remake module and it worked.

You need to clarify what module are you trying to modify and what do you see exactly.

First of all, this wasn’t made as override, you must edit the module and add prc_lite hak and tlk in it. Do you know how?

Second, this is tricky to do with campaign as you must copy campaign module into NWN/modules, rename the extension nwm to mod, then edit it in toolset AND then rename extension back to nwm and move back to NWN/nwm folder and overwrite! It won’t work otherwise.

If you do this correctly, you should see the new classes in selection window when levelup. Do you see them or not?

If not, you didn’t install the PRC Lite into module correcttly and need to follow the steps I posted above. If you have more questions about this let me know.

Now, if you do see them but you are unable to fullfill prerequisities then you probably have older version of the nwncx_patch that doesn’t have module event duplicates feature in it. Try download newest nwncx_patch here.

Let me know if this helped.


#5

The patch you posted was newer than the one I was using, however, it didn’t make any difference. I know how to install the mod, and added the .hak and .tlk to the PGC3 for easy testing. All of the classes show up and have proper descriptions, however, none of them are selectable when the requirements are met except for Champion of Bane, which as nakie08 pointed out, is the only one without spellcasting features.


#6

aaaaaa crap i think i know why…

wow for so long and nobody found it doesnt work at all…

The reason it doesnt work is that it requires one more 2da where are defined spell levels. I have this 2da in override so everything worked for me but the 2da is otherwise missing in project

hey I cant update the project right now, but if you save this as spelllevel.2da and put it into hak prc_lite or override it should work

2DA V2.0

      Bard   Wizard   Sorcerer   Paladin   Assassin   
0     -      -        -          -         -          
1     0      1        1          -         -1         
2     1      1        1          -         1          
3     1      2        1          -         -2         
4     2      2        2          -1        2          
5     2      3        2          -1        -3         
6     2      3        3          1         3          
7     3      4        3          1         -4         
8     3      4        4          -2        4          
9     3      5        4          -2        4          
10    4      5        5          2         4          
11    4      6        5          -3        4          
12    4      6        6          3         4          
13    5      7        6          3         4          
14    5      7        7          -4        4          
15    5      8        7          4         4          
16    6      8        8          4         4          
17    6      9        8          4         4          
18    6      9        9          4         4          
19    6      9        9          4         4          
20    6      9        9          4         4

#7

Adding that to my Override indeed allowed me to select most of the classes - except for Archmage. Even meeting the requirements, that one is still unusable. It also seems to be the most mechanically involved compared to the rest, which are mostly classes which advance caster level in some way without giving unique benefits.

Adding that spelllevel.2da to the archive if/when you go to properly update the project would make everything but Archmage work properly.

Despite the problems, this is night and day compared to the old PRC, which was a nightmare of bugs and jank and immersion breaking workarounds, whereas this feels natural and fits into the game like the other classes.

Might I suggest borrowing the PRC Module Updater to make installing this even easier? I’d love to help you with this project in some way, be it bug testing or mucking around with .2da files. Engine scripting is beyond my reach, however.


#8

Adding that spelllevel.2da to the archive if/when you go to properly update the project would make everything but Archmage work properly.

hmm i see two options

  1. for some reason script thinks you cant cast spells of level 7, you should see after levelup a debug texts where it says which level of spells you can cast, i tried it with sorcerer 14 and it correctly reported 7, make sure this value is 7 or more. Though, after closer inspection it seems I need to recode this as it doesn’t take prestige classes into consideration properly. The PM is coded into calculation but not the extra prestige classes added. So if you are something like Wizard/Eldritch Knight it won’t work. I try to completely recode this, the spelllevel.2da is also not ideal solution - as it requires user to modify it if he made any changes to spellcasting progression…

  2. You don’t have Spell focus (any school) . The class description is bit misleading I was also unable to get Archmage until I re-read the description - at first I just took random metamagic feat and thought it will work.

Might I suggest borrowing the PRC Module Updater to make installing this even easier? I’d love to help you with this project in some way, be it bug testing or mucking around with .2da files. Engine scripting is beyond my reach, however.

Not sure if it is reusable and if there are any permission issues… Might be easier to just make secondary version for singleplayer which will work as override? It would be little inconvinient to keep track of two version of the same project but it would surely be easier for user to install.


#9

Hello! Thanks Shadooow for helping.

Archmage is selectable for me now, but it seems aside from that nothing is working as intended. First thing I noticed is that the Archmage PrC has no class skill attributed to it. Second is that it doesn’t add its class to it’s base caster class to determine caster level(as I assume it’s supposed to be doing). I tested a 16 Sorc/5 Arch which is supposed to be 21 caster level but if I cast a Flame Arrow(which is 1 arrow per 4 caster level) it only casts 4 arrows instead of 5. Also tested it with Spell Power IV and it’s still stuck at 4 arrows which means Spell Power feat doesn’t work as well. All the other feats are non-functional too. They display visual effects on activation + the texts in yellow that instructs what to do next but the feats’ intended function doesn’t take effect as far as I’ve seen.

I followed most of the installation instruction to the best that I could understand them. I’m using Halls of Advanced Training Deluxe for testing. I added the PrC-lite hak and tlk into it. The only thing I’m really not clear on is the NWNCX, which, unlike Renzokuken, I’ve never had the experience of using before. I’m only installing for single player. As instructed I copied all relevant dlls from it and copied the EXE included and launched from that.

The NWNCX_patch I’m assuming is included in the CPP 1.72, correct? Also, the newer version you provided ITT has extra stuff in it like 2DA and NWNScript folders, am I right to assume those are for multiplayer/server stuff? I only copied the nwncx_patch.dll from it.


#10

The Archmage features should require 1.72 spell scripts to work properly. There is still a possibility I messed something up again - and Im going to check that, but if not, you still need community patch 1.72 and its spell scripts to make it work. This means that this feature won’t work in module with heavily changed spells, it won’t work with EMS and other spell-changes packages installed and it won’t work with older version of community patch. This should require 1.72 RC 1 at least, better get the latest.

yes those are for builders, you just need to put the dll into NWN folder and then run game via NWNCX.


#11

An override version would theoretically work as long as nothing in whatever module is being played overwrites it’s changes. It’s been a very long time, but I do remember that custom classes added to the classes.2da do show up in Override.

I just tried with Sorcerer and managed to make it work with a number of caveats:

-First, but not entirely related, Eldritch Knight became unselectable when I took a 21st level of Sorcerer on a character that become 25th level. The other 4 levels were Paladin.

-Taking 14 levels of Sorcerer and nothing else is what allowed me to select Archmage. EDIT: This might be user error and me forgetting to take Skill Focus: Spellcraft, which doesn’t seem to become selectable itself without a skill investment, and when I don’t see it as a choice, confuses me into thinking I’ve already taking it. This coincided with me testing out multiclassing, making me think the two were related.

-The feat description for Spell Power I reads “Spell Power II” instead of a proper description, which leads me to believe that its description points to the wrong place in the .tlk file

-None of the Archmage’s features function for me. I’m -fairly certain- that I’m using the latest version of the Community Patch. Spell Shaping still causes my character to be harmed by their own Fireball, Mastery of Elements doesn’t change my spell’s damage type, Spell-Like Ability does not properly store the spell I choose, and when using Arcane Fire, it casts the normal spell I use to fuel it instead.


#12

re lvl 21 issue - related to the spelllevel.2da it has only 20 levels in it and my script probably forgot to cap the level to 20 - either way im already working on this and I intent to replace the code to check arcane/divine spellcasting level with more robust code which will work with user modification and custom spellcasters too

re archmage feats not working - then i made error somewhere, I know for certain everything worked for me in the module I was testing it, I probably forgot to put another script into hak or something… working on this…


#13

Ok done. Try new version. Note this version has a lot of debug messages in it. They currently cannot be turned down by user using prc_lite.hak. I will add option to toggle it later once I make sure everything works as expected (finally).

https://neverwintervault.org/project/nwn1/hakpak/original-hakpak/player-resource-consortiums-lite


#14

It works perfectly now! Atleast the Archmage one does. Class skills and caster level included. Thank you so much!


#15

This one works half-way. It’s hard to tell if Spell Shaping functions as intended, however I know with certainty that Spell-Like Ability works without a hitch. I can store an Empowered Cold-Element Delayed Blast Fireball and throw it out twice per rest.

However, Mastery of Elements doesn’t seem to work with anything except those two stored spells a day, even though the Debug says that the element is switched. Arcane Fire still doesn’t seem to do anything, either.


#16

Can you send me the module you are testing this?


#17

This is the module I installed it in.


#18

everything works for me

To test spell shaping you must go to full pvp area, as in party and no pvp you wont get damaged if you cast fireball under your feet. I went into Arena area and it worked.

Mastery of elements also works for me, tried fireball (on self) and chain lightning on the dummy and it worked.

to test Arcane Fire you need first use feat on a target, then cast any spell on any target and a missile should fire towards target you targetted using arcane fire feat.

Note, you should see

------------------------
[DEBUG] Spellhook
...
...
multiple lines with text
-------------------------

everytime you cast a spell in chat log, if this is missing then you probably forgot update prc_lite.hak with newest version?


#19

The issues are reproducible. I’ve narrowed it down to only happening after the stored spell is cast. The spell can be stored and left unused and the rest of the class features will function as intended, however, the moment that Spell-Like Ability is used to cast, the rest of the features will break. Interestingly, Mastery of Elements still applies to the stored spell. The bug persists through saving and loading and I’ve attached a save with the bug for testing.

Save file. Uses the newest .hak and the module I linked previously.

EDIT: The debug stuff appears in chat, I should have mentioned.


#20

i see now it makes sense…