Problem with dsound.dll

#1

Hi all,

yesterday I felt like playing and by trying to launch the game I noticed there was no sound. So I close it, retry and again no sound. I restart my PC and try again, and get an error message when launching, and again while in the menu.

nwlaunch.exe (or how is called) - Bad Image.
the file dsound.dll is either not recognized by the system or is unable to run in windows.

dsound.dll is located in system32 folder and to be honest I don’t know if it is a nwn2 specific dll or windows. In any case, some research later I found out this was either a corrupted-defect file or a virus.

What I’ve tried to do so far

  • Replace the problematic dll. This was a chore since windows doesn’t allow the system32 to be altered. I managed to do it though, and the problem persists.

  • Uninstall and re-install NWN2. The uninstaller hangs and not responding.

  • Run the game from GOG-Galaxy. Same issue

  • System restore to a point where there was no problem. This is interesting. Windows reports that the file (Installation folder)/NWN2Toolset/plugins/de/animationviewer.resources.dll cannot be extracted and the system restore fails. I tried removing this plugin and windows reports the exact same problem. (The exact file might be called differently, I am not at home right now).

To this point I am willing to take any ideas. I am thinking of a general format if anything else fails. Now I had to go to work and I let my PC do a full scan and full virus scan.

#2

Try this: open the Windows command line tool (cmd.exe) as administrator, type “sfc /scannow” and press Enter. Wait until it finishes and see if it helps you.

#3

Sorry, forgot this step. I also tried this. It hanged at 42% for a while (10 minutes or so). Then it continued and ended fast especially after 70%. Like, 2 seconds to go from 70% to the end. It was so fast I didn’t even notice if it actually finished or if it ended abruptly It reported that something went wrong. I forgot exactly but I got the status message at home.

#4

The dll file was actually corrupted. Had to do some windows repairs but it works now.

1 Like