Question for windows gurus

hi all,

i recently installed windows 7 on a new pc and i’ve been having problems with various nwn-related applications. i don’t know if these are related.

in the toolset, the previewer will now only display the 3d model of a blueprint. whenever i choose the 2d radio button, there may sometimes be a brief flash, but the image displayed is still the 3d image.

i can no longer resize panes in either axe-murderer’s killer talk editor or jlen’s .set editor. whenever i grab a handle or an edge to move a pane, the pane just snaps right back into place or doesn’t move at all.

there are graphics bugs in both leto and nwnarmory. it looks like some of the background images are actually missing, but i did a fresh install of both, and it didn’t solve the problem.

all of these applications worked correctly on my previous install from about 3 years ago. it’s the same version of windows [win7sp1 enterprise n]. however, i did apply all of the recommended patches from microsoft during this install session ; could one of them have broken things ?

could this be a problem with .net, or some sort of direct-x thing ? or is it more likely i’m looking at a bunch of unrelated errors in the applications themselves that just coincidentally happen to be buggy all at once ?

all my video drivers are up-to-date. also, i’ve tried each of the programmes on the various windows xp emulation modes, and that doesn’t solve the problem.

i’m out of my depth w/windows, so i was hoping someone who knows how to get around better might be able to point me in the right direction to at least kick off some troubleshooting.

Make sure everything you are using is set to run under Windows XP Compatibility Mode service pack 3 and set to run as Administrator. If you still have issues and your computer has two or more CPUs, try forcing the CPU Affinity to a specific core. On dual core comps, I’ve found setting the affinity to “1” (the second core) often helps. There should be CPU Affinity switches in both your nwnplayer and nwntoolset “ini” files. Generally “0” is the default and tells Windows to use whatever CPU it feels it should. NWN likes to suck up the whole CPU at times on older computers and enforcing a single processor often helps.

1 Like

thanks for the reply, @kalbaern. yeah, i’ve got them all set up to use xp compatibility mode, but that doesn’t solve the issue. in fact, i’ve tried pretty much every permutation of xp compatibility mode, run as administrator, disable visual themes, disable desktop composition, and disable display scaling – nothing works.

i thought this might be an issue w/.net, so i downgraded .net from 4.8 to 4.5, then to 4.0, then to 3.5 – didn’t solve the problem.

i desinstalled vc++ runtimes back to 2008, still didn’t solve the problem. so now i don’t think it’s a problem w/the applications themselves. but i’m clueless about where to go from here…

since a picture’s worth 1,000 curses, here’s some more vilification :

here you can see the points on the gui that don’t resize. i should be able to double-click the header joints, or drag the bottom pane upward, but when i do, they snap right back into place.

leto seems to be missing some textures… :frowning:

here you can see where the underlying gui is sort of ‘covered up’ by the windows display frame, and notice that there’s nothing to grab on to and no way to change the geometry. :unamused:

and of course there’s the toolset previewer – well, you don’t need a screenie of that.