Really weird tileset problem

I am using @rjshae’s and Ancarion’s excellent Sci-fi base tileset: Sci-Fi Base Tileset for NWN2 | The Neverwinter Vault
, but I’ve run into a super weird problem. This is what happens:

  1. I’m in an area (area1) and teleport to another area (area2). From there I teleport to the area (area3) with the tileset problem.
  2. When getting to area3, the tile Hallway End variant 3, used with two instances of Plasma Door 1, the tile and the plasma doors won’t show. Everything else in the room shows great and everything works.

Ok, now to the weirder part. Alternative scenario 1:

  1. If I’m in area2 and teleport from there directly to area3, the tilesets and the plasma doors show up.

Alternative scenario 2:

  1. If I’m in yet another area and teleport from there to area3, the tilesets and the plasma doors show up again.

Alternative scenario 3:

  1. One time when testing, when in the same area as in Alternate Scenario 2, and teleporting to area3, now the tilesets and the plasma doors wouldn’t show. What I noticed happening before teleporting that time, was that the PC floated across the ground (a bug that appears in some areas at some random times).

So, my conclusion to this is, ok, maybe there’s something wrong with area1, but I did however experience the bug in scenario 3 so… Area1, and my whole module I’ve began working on now, uses the star wars tilesets from the abandoned star wars module (there’s a thread about it here on the forums), and I use a Metatile from that abandoned module in that area. Could that perhaps screw with things? Maybe that metatile is corrupt somehow? In Area2 I use other tiles from the star wars module, and when transporting from there (unless beginning in Area1) it works.

All this is very strange. Does anyone have a clue as to what could be going on here?

Alright, it gets even weirder. I tried with erasing the plasma doors and using all the other variants of the Hallway End and baking the area. Now when teleporting from area1, all these other variants show up. Then I went back to variant3, added the plasma doors, tested, and now teleporting from area1, I can see this tile. However, when baking it looked like this at first:

Then, just for the sake of it, I rebaked the area, and now it looks like this:

After rebaking, when teleporting from area1, the tile and the plasma doors won’t show up again.

So, if I try and bake this area so that it looks like in the first picture, everything should work, right? But…is it really baked correctly in the first picture? All this makes me a bit scared it will cause other bugs, I don’t know…

EDIT: Testing this from the beginning, with the first scenario (see first post), and not rebaking (the baking looks like in the first picture) the error with not seeing the tile and the plasma doors is back again. Maybe I should just abandon the idea of using this tile. It’s not necessary to use, it just looks a bit better than what I would use otherwise.

The second image is how it is supposed to look when baked; you have two cells and the rest of the tile is blocked off. Maybe there’s a duplicate name issue with the tile walkmesh? Otherwise I don’t know.

Ed.: I double-checked the tile model and everything seems fine.

Yeah, I switched to another tile and using the green glowing door, and now the tileset works but the door isn’t glowing, but it’s there at least. Funny thing is, I have another green glowing door at the other end of the room and it is indeed glowing green.

I have no clue as to what’s going on, but I think I’ll leave it like this for now.

You perhaps could have (without rebaking) replaced it with an open tile, carefully put on a walkmesh cutter to match the outline, then switched the tile back. That way when you bake the cutter takes precedence.

The wall mesh has an unusual shape, so perhaps that has something to do with the issues? :man_shrugging:

I’m quite pleased with how the area looks now, apart from the door not glowing. So I won’t go back to using the tile in the picture. However, the not glowing part of the door really baffles me, 'cause everything works as it should, and looks nice, otherwise.

Does it still not glow when you’re in the game? Perhaps something was corrupted.

Precisely. It won’t glow ingame. In the toolset everything looks fine. Maybe something’s been corrupted, but I don’t want to redo the whole area from the start now that I’m happy with it otherwise.

This type a problem is usually a 2da problem. Something isn’t set correctly, or names overlap.

1 Like