Same Files, Different Computers - One Compiles, One Does Not (Memory Limits?) - SOLVED

Hi All,

SOLVED: See below.

(EDIT: Just realised the older forums were “closed” and so post again here.)

I know it has been some time since I last posted, but I have been taking a (needed) break.

However, today, I thought I might start looking at some MP debugging for my module, The Scroll.

I had a nasty surprise when one of my computers FAILS to play the module!

At first I thought it was due to some missing or corrupt files, and so copied across all from the main computer. However, the game still “crashes” on the second computer at module startup! When I went to look at the files on the second computer, the files came up with a “error” from an “include” file, which it does not when tested on my main computer.

i.e. The inlcude file compiles on my main computer, but does not on the secondary one. (And yet they are exactly the same files.)

My main computer has more memory than the older (second) computer and is the only thing I can think of at the moment.

Can anyone shed any light?

Thanks again all.


Hi All,

SOLUTION: Had to reinstall NWN2 and update again. It looks as though a Windows Update may have corrupted some of the core game files. (E.g. nwscript - especially the 1.23 script fix updates) All works fine now!

Cheers, Lance.


A Linux native version of this game just cannot come out soon enough.
Will it happen before I die? One can only hope.

That has happened to me multiple times. I don’t know what micro$haft keeps changing but it drives me nuts.