Scourge of the Slave Lords - Corrupted module

Hi. I’ve posted about this on the module’s page, but I don’t think the author is around nowadays (sorry if that’s not the case, but at least his last visit to the Nexus appears to have been over a year ago), so maybe someone here knows if or how it can be fixed. The issue is as follows:

When I try to start the campaign, the game sends me back to the main menu and gives me a message saying the module couldn’t be loaded and the file might be corrupted. I’ve tried downloading the files both here and on the Nexus, including the ones from an older version of the module, but the problem persists. I know of the same thing happening to at least a couple more people, so it’s not an isolated issue.

Maybe only the author can fix this, but any help would be appreciated - even if it’s just to confirm that. Thanks.

1 Like

bealzebub was here about a year ago as well. You could try his profile and see it lets you send an email.

That mod fails for me too. I think I managed to fix it though - I converted all four of the mod files into directory format. Delete all four of the original .mod files out of your modules folder. Leave the original campaign, TLK and HAKs though. Extract this into your modules folder:

Let me know if it works.


I’ve ran the module many times with no problems. If it persists, let me know . . . I can send the files I have. Last I heard @bealzebub was working thinking about working on the Drow modules.


Thanks everyone for the replies.

@travus your method worked, both for me and a friend I mean to co-op it with. Many thanks! :clap:

@Sawdust37 it seems there’ll be no need for your files then, thanks. At first I thought something might have gone wrong with the latest update, but that theory fell apart when I had the same problem with the old files on the Nexus.

@GCoyote that was my initial idea, but I figured he might get a PM here on the Vault instead of an e-mail that way, and thus probably miss it if he’s not around. Hopefully he still visits from time to time and can update the module’s page with the fix.

Thanks again!


OK then . . . glad you got it up and running . . . it’s a fun mod, especially if you played the old D&D modules.


Hi Arkalezth,

I have the same problem with Scourge of the Slave Lords. I did try Travus’s fix, deleted the original mods, extracted his slavelords.7z into the molules folder although once I start the game the modules don’t show up under “other modules”. The slavelords.7z extacts folders not mods, I’m assuming that’s the issue but curious how it worked out for you.


Hi. Neither me nor the person I was playing with had any further issues after installing Travus’ files. The only insight I can offer is to make sure you placed the folders in “modules” as they were, without pulling out any of files they contain, and once in-game, to see if it appears in “new campaign” instead of “new module” (I don’t remember which one it was and I can’t check at the moment).

I know it’s not much, but if that doesn’t help, then I’m afraid I’m out of ideas.

That was a quick reply to an older thread, thanks very much that was awesome.

Still not working for me, I’ve extracted the zipped “slavelords” folder into the module folder. And even tried copying the “a1- slavepits” etc folders direct into the module folder as well. Neither shows up in the game menu.

I’ve doubled checked and have the hak, tlk in the correct folders. And I created the campaign folder within the neverwinter directory, and have the “sotsl_campaign” folder within, as well as a copy of the “scourge_of_the_slavelords” folder within the campaign folder (wasn’t sure which folder was to be directly in the campaign folder, so I doubled up to be safe).

With all that, within the game there’s still no slavers campaign or module option I can see.

I’m running a new copy of NWN EE.

And I don’t see a “new campaign” option only an “other module” option

  • NWN Campaign
  • NWN Shadows
  • NWN Horde
  • Premium NWN Modules
  • Other Modules

I’m stuck, but I do appreciate that you replied and if anything jumps out at you as incorrect please let me know.


Figured it out, need NWN2 not NWN EE.

Thanks for your help

If you check out the vault there are some different versions of the Slave Lords you can download, and someone did do the G1-3, D1-3 and Q1 and they did a sequel Q2 all for NWN1 which should run EE. I haven’t tried them out yet but I plan to sometime.

1 Like

You may like to check out Against the Giants A 1-3 for NWN 2 here on the Vault Bealzebub did a much better job with these modules. Most of the bugs were a few tiles showing grids in places which may be fixed by now. G 1-3 is a SOZ style party system so you can use your own characters instead of the npc’s from Scourge of the Slave Lords. Bealzebub was working on D 1-3 the last I heard.


Thanks for the head’s up, I appreciate all the followups and I will check out bealzebub 's work.

I did ultimately get SotSL working, and in hind-sight pretty simple, I needed NWN2 and all the files from

Scourge of the Slave Lords / Submitted by bealzebub on 2015-02-17 19:47.

Worked. Didn’t need the slavelords.7z from Travus.



travus, you are awesome!

The .mod files didn’t work for me, but yours did. Your files should be added to the module’s page.

My co-op buddies and I give a big THANKS!



Hey, sorry to necro this old thread, but I was running into the same issue. Unfortunately, @travus 's files have been taken down, so I couldn’t use those.

The up side is, that I had to do a little independent digging. I couldn’t figure out how to unpack the files into directory format, which caused me to start playing with potential conflicts.

In my case I was using the nwn2 Client Extender. When I load the game without it, the module loads correctly. I wanted to make sure I added this as a possible solution for anyone else who stumbles here trying to find a solution.

I made a new merge-patch for Slavelords/Against the Giants a couple years ago. Not only does it fix bugs in both of those mods, but it also combines them into a single campaign. The install instructions are in the download:


@travus Thanks very appreciated! I’ll give that a go today, as it’s definitely preferable for me to use the client extender.

Also, is the AhTravesty YouTube channel your? Been enjoying the replay of this campaign as I play through myself.

Yep, that’s me, too :slight_smile:


Sorry for another question. Up until I reached Istivin in G1 everything was working, more or less, well. I’m now at the point where the Hill Giants should be marked on my map, but interacting with the world map transitions does absolutely nothing.

Has anyone else had this issue, or know any workarounds?

I’m assuming you spoke with Lashton and Randos in Algorthas’ place, and they said they would update your map with the location of the hill giants?
Are you still using the merge patch?
There are two world map transitions in Istivin - Did you try using both of them?
When the world map comes up is the Istivin icon visible?

1 Like