Server not finding resources?

Hello all. We’re putting up a new server and doing some testing on a basic module to ensure everything’s working (database connections, nwnxee functions, etc.).

The server is run via docker with NWNXEE on a Linux VM. Right away we ran into an issue. Functions that referenced anything from dialog.tlk (like GetStrByStrRef) weren’t returning anything. I copied the stock dialog.tlk into the server’s base directory and it fixed this issue, so I’m assuming there are some resources missing somehow.

The next issue I ran into was the lack of a placeable showing up in the module, specifically an anvil (resref: plc_anvil). When I run the module on my computer, it shows just fine, but on the server, the placeable does not show up. On a hunch, I copied base_2da.bif to the server directory and the anvil showed up, but it wasn’t interactable. But, of course, ever since, the anvil has not showed up again in the module while it’s being served. Also, I could not find a reference to plc_anvil in any 2da file I looked it, even though it’s available in the toolset.

Anyone run into this type of apparently missing resource before? If so, any idea how to fix it? Or is it some other type of issue?


copy your dialog.tlk to the server home dir or update to the .10 version. .9 is missing it.

Thanks. That’s the part of the solution I was able to figure out. It’s the missing placeable I can’t seem to tackle. I confirmed with the nwnx docker experts that my docker image has all the required game resources, so I’m at an impasse as to why this placeable won’t show.

So new twist, turns out the placeable exists in the module when you start the module, but fades from existence after about 5 seconds, never to be seen again. It’s marked plot and this is a stock NWN placeable, nothing special about it. Anyone seen this type of behavior before. There is no scripting that would destroy it…

So, weird resolution to this issue. It just stopped happening. The anvil just stays where it’s supposed to be. No game updates, no code changes, no new modules. It just works now. Gotta love computers.

Well, if there’s something lovable about computers, it’s that usually you can find all the variables if you care to look deep enough.