Server where I play often crashes

I was looking for tools to trace the issue.

At the moment I have found this 2 links:

The tool is Game Server Manager, I don’t know if it will work even if you don’t have steam, I guess it will do.

Do you know more tools to monitor the healt and trace and debug issues with a neverwinter server?

Thanks in advance


I also found this link:

Neverwinter nights extender. Also is able to monitor the server.

Any other tool?

Thanks in advance.

Is the PW NWN Diamond/1.69 or is ir NWN:EE?

Sudden crashes often are not recorded by various loggers, even with NWNX2.

In most cases, a server just doesn’t randomly “poof” either.

What is the server? How often does it occur? Does it go down and stay down or does it pop back up again by itself? Is it an IP issue, IE, do you just get disconnected but when you return later you pick up where you had left off? When did the problem first arise?

Hi, thanks for answer me.

It’s a PW Diamond 1.69.

It happened this dates:
Oct 5, 2019 at 1:11pm
Oct 7, 2019 at 3:07pm
Oct 9, 2019 at 0:1234:

The server has something I think that allows to relaunch but as there was a error (owner didn’t give more details) the server wasn’t able automatically start…

I don’t think is a IP issue.

When I return all has been reseted. T

It has been happening time ago.

Regards and thanks for your help

It should be the server Owner/Host posting. Not knowing which PW … what haks are used … the modules size … scripted systems … details on the hosting computer and tons of other things, there’s just going to be a lot of tail chasing.

Thanks anyway for your help. The only rare thing I have seen in the server when I play is on the game log that says: mod_onlogin script, too many instructions. Today the server has offline too. I saw too many instructions in a area like 30 minutes before crash but not with onlogin script. I don’t know if is related with crashes.


It could be but could also not be. Poor Too large of inventories and inefficient/outdated scripts are most often the cause for TMIs that occur when a player joins the server. This can often be resolved by simply taking the script in the OnClientEnter event of the module and breaking off some of the functions into separate scripts fired using " ExecuteScript" with slight delays between them. Encouraging folks to slim their inventories helps as well. It is most often when a script has to loop through inventories to find faction tokens, check items for validity and other things that when combined with a little lag will cause the scripts to time out. I highly doubt this is also the cause for crashing, but rather a symptom of other issues there.

Thanks a lot for your help. I’m searching also for monitoring solutions like Game Server Manager v3.6.4.0 here and I’m looking for more advanced monitoring solutions but I guess the owner won’t want install nothing on server. Anyway I’m trying to do as much as I can to help.

I have seen too a neverwinter nights 2 tool to detect if a client connect from the same router with the same port so I guess that issue can happen in neverwinter nights 1. There is a player who is connecting with 3 accounts so I think he will be doing it with the same router and same outside ports? I don’t think that’s the issue because he often connects and server works fine.

I have no more data to give you. I would like to have access to server windows logs, game logs but I don’t have it.

Regards and thanks again for your help

As was stated earlier in the thread, this problem really needs to be handled/debugged etc by those running the server. There is very little you can do as a player to get to the bottom of this.

1 Like

You can host and play from the same computer without issues.

If two or more folks play suing the same IPs, it generally won’t crash the server. It often however glitches one or more of the characters that have connected.

Utilities that log and monitor various “things” while the module is up do not often help pin point the cause of crashes. Lag … yes. But even when something causes lag, it may or may not be the reason for crashing.

If the server “auto restarts” then most likely NWNX2 is in use and is capable of logging scripts and stuff already.

Does the server use the CEP? Players with a version other than the specific one used by the server can cause issues at times.

Anyone building in a module using CEP 2.4 or older when they have CEP 2.65 installed on their computer can corrupt areas/placeables/creatures unknowingly at times.

CEP 2.3/2.4 modules that didn’t later add the crash fix for Hardpoints Dragons can have unexplained crashes when a dragon using their appearance spawns in or appears on a clients screen. Not just crash the client, the whole server. Modules made with or updated to CEP 2.65 are fine.

Depending on what haks are used, sometimes their names overlap hak sets used elsewhere. I myself had some issues when other PWs used some or all of my own haks (which is fine, if I post it … go for it) and I had players hopping between my own and their PWs. Overtime, rather than add tophaks or other renamed haks as they expanded, they added things into the haks I had named and while it was fine “over there” it caused almost impossible issues, including some crashes on my PW. In the end, I ended up renaming my haks to resolve the conflicts.

Even the best profilers can fail to detect a script causing a sudden crash. Sometimes it all happens in an instant and the server processes have crapped out before whatever script is the issue gets logged.

Sometimes, most often when the server is used for other things like the Host playing, or just web browsing or the owner playing something else that can be the cause. Or a #@%!#^ windows update downloading.

Again … way too many unknowns. Rather than look for fixes yourself, because its highly unlikely you’ll find one, have the Host/Owner/Da Boss, come here and give details and ask for help. Some folk are just stubborn or are afraid of how they’ll look if they ask for help and some hosts have inherited a PW and host it but have no real experience maintaining, expanding or scripting a module. In these cases, they could still PM “someone” here in regards to their issues. The NWVault Discord Channel is another good place to seek assistance.

Thanks for your help.

Owner wrote what he saw on logs:
This is what I saw in logs
[Fri Oct 11 08:16:50] Unknown item unacquired by <Aragorn|Judge Dead Turn
SpellLikeAbilityReady: Could not find valid ability in list (Spell ID=368).
[Fri Oct 11 08:17:02] Ettin Was Killed by Aragorn
[Fri Oct 11 08:17:02] Ettin Died

[Fri Oct 11 02:32:56] *** Less than 20 minutes left till reset: 0.000000000
[Fri Oct 11 02:32:56] *** Timeleft < 0, doing delay restart 0.000000000
[Fri Oct 11 02:32:56] *** Executing restart module on Naria
and I guess server didn’t reset.

Something is causing server restart and is not restarting because of some error is not on logs. Could the spelllikeabilityready could not find valid ability in list cause a restart? I think maybe not because hours difference between that record and the record of restart.

If I look at the spells.2da file content here
I find that 368 ID matches with icestorm. The character Aragorn is a cleric (I know it) and it’s pretty strange that SpellLikeAbilityReady error. I know that the server has many customized spells and feats so I’m asking what spell matches that id to see if for example is turn undead from cleric.

If I have more information I will keep update.

Regards and thanks for your help again.

The generic spells 2da may or may not be valid. More than likely there’s a custom one used by the server either as a server side hak or as part of other merges in a player/server hak. Regardless of the errors displayed, the 4 hour gap pretty much eliminates it as the cause of a crash.

Without seeing how the “restart” is scripted and employed, I can’t say if the logs show an issue or not. It’s possible that when it reaches the 20 mins until a restart phase that is defaults to instant if no one is in game at the time. As for it not popping back up … again, there is still a dearth of missing information.

Unfortunately, I can’t view the forums for the PW in this topic as you are required to make an account before even viewing. OK … let me rephrase … I’m unable to because I’m not going to bother joining yet another forum, especially if I don’t intend on actually playing on that particular PW. I can understand not being able to post without first joining, but not being able to read a few basic requirements, haks required, game style and other things is just silly … unless you goal is not to have others find your world in which case … well done.


The server I play is aventia:

I don’t know what modules are using with neverwinter extender, I only know they have lot of customized feats and spells. It’s a persistent world with no levels limit but many customized things. My intention wasn’t bothering others or others can’t find that server I play. Even more, while more players better.


In this thread … My server keeps crashing when it tries to restart
Your host mentions the toolset is CEP2.1.

They “think”. They stopped responding there.

Two other old links to Aventia modules on the Vault mention CEP2.0 and CEP2.3 (or higher). If someone has added to the module or made changes to it and they had CEP 2.6-2.65 installed, there’s a definite chance they’ve broken more than a few “things” in the module. Some CEP releases are backwards compatible, others not. CEP 2.60+ is not compatible with many modules built under CEP 2.4 or earlier. They can be made to work under the newest CEP release, but it takes some time. Each area usually needs gone through as well many of the items, creatures, placeables and other things. Often it’s just a matter of merging the old 2das into the newer ones. Usually a custom tophak needs made to incorporate and merge the old with the new.

A start would be for whoever is building/maintaining this module to go back and delete their CEP haks and download the old CEP2.3 and load up the module. Then make sure the remote server uses these haks as well. I suspect things will run smoother. Here’s a link to 2.3 and 2.4.

Hello again.

At the moment of crash only 2 players were connected, me and another player. I’m using CEP 2.65, I’m going to try uninstall it and install the CEP you are advicing. How must I uninstall CEP 2.65?

Finally I uninstalled completely the game and try with CEP 2.3. I will advice on forums about having high CEP version with old modules.

Regards and thanks for your help

I tried with CEP 2.3 and server says I don’t have cep_v2.3.tlk. I’m going to install again 2.65.


Apparently I was unclear. I believe the module itself is glitched due to someone working on it using the wrong CEP version.

No, you were clear but just in case and as in the forum says works with CEP 2.3 and higher versions I tried to test it with 2.3 and see if it didn’t crash. I’m going to ask in forum what cep version are using and if there is possible to rollback server cep version to 2.3 and test stability.

Regards and thanks

Hello again. Today server went offline again but was working fine until all players we were playing started lagging like if server run out of memory or cpu. I can’t assure this because I’m not managing the server and I doubt it has monitoring tools installed on it.