Shiny Water issue in 8177 - SOLVED

As of Development Release 75.8177 I’m seeing moving black dots in Shiny Water.

This problem is somewhat unusual because it only seems to be happening in my module:

  • It doesn’t happen in a new module with no haks
  • It doesn’t happen in a new module with the same haks as my module
  • It does happen in a new area in my module

Can anyone suggest what might be going on here?

Is the new area in your module using the same fog distance, colour and amount as in the picture provided?



However, the same settings in a new module work fine.

Also, areas in my module with bright daylight have the same shiny water issue, just a little less obvious.

After several careful experiments, I confirm the same bizarre conclusion - something in my module is triggering this, but it’s not the haks or the nwn configuration.

Unless anyone has any better idea, I might have to do a binary chop on the content… which could take forever…

I seriously doubt these are better ideas… but here is what i got:

  • Did you check this is not a corrupted module problem ? (check an old version to see if you can reproduce the graphic bug).
  • Did you try the hardware path ? I remember similar visual artefacts when graphic cards were failing or overheating (open your pc case, launch the game, look if the gpu card fan(s) are rotating).
  • New patch problem (don’t know if you can revert to an older version with NWN-EE, but could be worth testing).

As a not too unrelated story, i must say that for me NWN-EE still has problems with legacy hardware… With spare old parts, i made a dedicated PC only for it; and my old faithful 7800GTX persists doing strange things. Was forced to deactivate “shiny water” because some chunks of the water plane randomly appeared above my character’s head, and sometimes clothing and armor displayed flying all around. I tried a lot of old different graphic drivers without luck and, of course, not a single problem with the 1.69.

Some lessons learned: EE BeamDog Desktop minimal hardware requirements are wrong. I think they just copy/pasted old NWN requirements, but in fact you need more grunt if you want to use the new eye candy. Probably a two gen later midlevel CG (Geforce 100 or 200 series ?) with up to date drivers, a dual core CPU, and 2 or better 4 Gb memory (and don’t start me on the awfully inefficient BeamDog client needs :rofl:).


@CaveGnome thanks - that prompted me to try the HDMI port on the motherboard, which works fine, so evidently the issue only affects the nVidia gpu.

My kit is well over spec. Other modules work, so nVidia card failure seems unlikely.

The bug exists for old versions of the module, but was not present before 8177.

So, something in 8177, coupled with something in this one module that is not custom content, is causing an nVidia issue.

One thing I can’t entirely rule out is some corruption in the module, going way back, that is only now surfacing as an issue.

This looks like new specular map overlying previous animated water texture - but that’s simply my guessing - I don’t have NWN:EE. To verify - you will need to search new patch content for new water models or textures, extract and compare with appropriate content from NWN 1.69

@DrA good thought. I wanted to examine the EE water textures, but I have an open query on NWN Explorer, as the EE version doesn’t work for me. I found a very old bif unpacker on Rolovault, so next time I’m at my desk I’ll try that.

@DrA I wasn’t able to unpack the EE .bifs because chitin.key or equivalent is nowhere to be found (other people have asked but maybe Beamdog don’t want this done yet). It is possible to open the .bifs but the file names are encrypted as res109…tga or similar.

However, I did override the water textures used by the tile in question (including the .txi) with the originals from 1.69. The bug is still there, so it’s not caused by a change to textures, as far as I can see.

Can you try turning off all the FBOs one by one and see if one (or multiple) of them are causing the issue?

I’m suspecting SSAO.

Unpacking: chitin.key doesn’t exist anymore. It’s now called nwn_base.key. If you need a command line tool that can do that for you, have a look at ( for recent-ish downloads)

@niv Thanks for that, but all the Frame Buffer Effects are off in the screenshot. Toggling them (stand alone or in combination) seems to have no effect on the problem.

EDIT - the only advanced video option that makes the problem go away (apart from turning off Shiny Water) is reducing Overall Graphics Quality from Best to Good.

I see that the command line tools have syntax help, but I probably won’t be able to figure them out without helicopter view documentation. Don’t worry, though - the override I described above has pretty much eliminated any doubts about the EE texture files).

@Proleric The old NWN Explorers work fine for EE but you just need to copy nwn_base.key file from the data/ directory and paste it onto the parent directory then open it from there. This is because the old NWN Explorer expects to find the .bif files in the data/ directory under where the .key file is found (such is the case in 1.69). I am using NWN Explorerer Reborn 1.63 found in the vault and it works fine with EE.

@pscythe Doesn’t seem to work for me. I copied nwn_base.key and the 1.63 exe to the 00829 root folder. However, starting that copy of NWN Explorer still opens the 1.69 game files. Using the Open button, it’s possible to open the EE .bif files, but they’re still encrypted. What am I doing wrong?

Yes that is the same for me too. But if you go and open the newly copied nwn_base.key file now it should all just work. You don’t open the .bif files yourself.

Just discovered that! Thanks!

The Open button in NWN Explorer can be used to open the copy of nwn_base.key in the 00829 root.

I’ll just have to remember to copy the .key file for every new release of EE (currently weekly).

1 Like

Virusman released a NWN Explorer updated to work with EE.

And yeah, testing your module, the same happens with my PC :frowning:

1 Like

Is it tileset-dependent?

@Soren Well, City Exterior, Rural Grass, Rural Winter, Mountain and Desert all have the same issue.

Forest & Castle Exterior - Rural don’t have the black artfacts, but look like a churning mass of goo.

All except Mountain & Castle Exterior - Rural are CEP versions, but that’s not the issue, because the titlsets work perfectly in a new module.

@dafena Yes, the Virusman version might be preferable, but you still have to use the Open button on the root copy of nwn_base.key.

Well, makes sense if it’s the water shader then - iirc forest and Castle exterior water don’t use that.

Does it occur if you make a new module with the same haks and then import the area(s) to that?