Shiny Water issue in 8177 - SOLVED

I exported one area to a new module with the same haks - the problem went away.

Hmm, that sounds pretty bizarre.

Hak order the same? Really can’t wrap my head around how a module corruption could cause this issue.

@Proleric @Soren

About the only change I can think of that could cause this, is the one where we fixed toolset objects like sound objects not having a colour; and gem items on the ground looking broken.

The fix was to take colours from the vertex shader if no texture was bound. You can see it in ovr/fsc_sm.shd.

Hmm, a bit surprised if that affects water - isn’t the only fragment shader on water fswater.shd or is that applied on top of something else?

Did notice in fsc_sm.shd though that it has

color.a = globalColor.a;

… which somehow seems odd and deviates from the other shaders, but I wouldn’t really be able to tell if that’s intended.

It should be easy enough to test, I think. Remove the new shader and see if it still occurs.

1 Like

@niv Removing that shader didn’t fix the problem, nor does removing all shaders.

This is seriously weird.

  • Exporting the area into a new module with the same hak order works fine
  • Cutting the module down to one area is still bugged
  • Loading the entire module contents into a new module (using nwhak) is still bugged
  • Deleting all scripts is still bugged

SOLVED - this bug occurs when Dawn and Dusk are set to zero in the module properties.


That’s most certainly not solved. It’s probably a bug in the shiny water shader. Thanks for the gruntwork, I’ll look into it.