Short question about Day/Night settings in area

So I have an area where I want there to always be night. I have set Day/Night cycle to FALSE, Directional light casts shadows to TRUE, Has directional light to TRUE and Always Night to TRUE. However, once entering the area from the toolset it’s still day. How come? I mean, I can change the default to a night setting, I guess, but must I do that? Shouldn’t it work with if I have set Always night to TRUE that it is indeed always night?

1 Like

Maybe it’s because you’re in the toolset that the toolset uses the default lighting. Did you test in game?

Try setting these to FALSE.

For if you have Directional Light as TRUE, then that would imply (as I read it) that the “sunlight” hours would still have an impact, even though ALWAYS NIGHT is TRUE. Untested though.

i.e. Perhaps ALWAYS NIGHT only refers to a time setting rather than a light sighting? (Never used it, so this is just a guess.)

Just tested it. It’s the same.

Turning these Directional Light things to FALSE just makes the area look weird. It’s not night…so that’s not how to solve it either.

I don’t quite remember how I did these kind of things before, but I might have done it with having every Day/Night Cycle stages having the same night setting. I just find it weird that it doesn’t work like it should work.

andgalf… You have to change the default to a night setting but it’s really easy. Just go to the module properties and click the arrow thing next to export export, then environment settings, day night cycle stage, choose a night one, give it a name and then do the reverse and import it back to default.

Always night gives you the big moon, it’s a bit tricky because of the controls to move it but if you zoom out in your default night scene and spin the camera about until you can see the moon ( look for which way the shadows fall for a clue ) then select sun moon direction and move it so it’s somewhere visible. It will give you some light and looks good too.

1 Like

I forgot setting day night to false is needed that will automatically stay on default so you can do this for anything like permanent sunsets etc. Leave directional light on for moon light etc.

1 Like

Yes, that’s what I meant that I have done before. I just find it weird that it has to be like that. It makes little sense to me.

Yeah, that makes kind of sense. I think I did this in my third module but I don’t remember.

So then the only reason to set it to Always Night is to get the big moon? That’s weird.

Sometimes NWN2 is so odd.

andgalf… I think always night just does that, it;s the only difference I can see. I’m off to test something with the sun maybe that can go massive !

You can change the module time settings so time goes slowly if you want things to still move but it will affect all areas and then you have to do time setting on enter stuff to get it right.

When I googled this I found I had asked about the same question back in 2017 on the old archived forums. Reading through the replies there, everyone just keeps saying that to have a Always Night (or Always Day) setting one has to:

  1. Set the default to a night setting (or day setting if it’s to be always day)
  2. Set the DayNight cycle to FALSE

But I can’t find ANYWHERE someone giving a logical explanation as to what Is Always Night? set to TRUE is for. If it was to have a big moon, shouldn’t it have been Is Always Big Moon instead? Maybe Obsidian just put this setting in the toolset but forgot to actually do something with it?

andgalf… I’ve solved your question always night turns the sun into a moon and gives you stars so you will get a night sky even if it’s daytime !

If your still doing your outer space stuff get the moon out of sight, remove the clouds and use this for stars and I think you can also change the moon into a planet by doing it’s colour setting. you might even be able to have weird coloured clouds floating about I’m not sure.

Huh? Ok…I just tested this. If DayNightCycle is TRUE and IsAlwaysNight is TRUE then nothing happens. However, if DayNightCycles is FALSE and IsAlwaysNight is TRUE then the sky is just as bright as if it was day, but there are indeed stars in the sky now. So you seem to be right, Tsongo. I can see no sun however, but I can’t see any moon either. Maybe that’s because in my settings somehow the sun and moon is hidden?

Ok, this was interesting.

So to conclude everything:

If you want always day or always night:

1. Set the default to a night setting (or day setting if it’s to be always day)
2. Set the DayNight cycle to FALSE
3. Set Is Always Night? to FALSE

If you want stars and a moon even if it’s daytime (and you don’t want a sun):

 1. Set Is Always Night? to TRUE
 2. Set the DayNight cycle to FALSE

EDIT: This post is not entirely correct. Check the following posts for clarification.

I think I solved this already but I don’t quite remember… but this module is still on hold indefinitely until 4760 has the time to convert spaceship placeables to creatures with some basic animations (so that I can do a space battle).

Until then I continue with the module I’m working on now, which is about 75 % finished (or something like that).

andgalf… Nearly except for number 3 that is just for day settings without a moon… Set is always night to true if you want a night scene with big moon and stars.

If you want to move and see the moon / sun you have to find it, this is easier on sunrise, sunset and moonrise etc, because it’s low and on the horizon then just move it up with the direction setting. So export one of the nightime settings that are not the actual night one and keep the moon low then whizz it about.

I tested it and with cloud cover set to 2 there are hardly any clouds and you can change the moon colour so planets in space are good to go !

Do I understand you correctly if I say: If you set DayNight cycle to TRUE and AlwaysNight to FALSE you NEVER get a moon when it’s night? Is that what you mean?

Ok, that sounds really cool.

Hmm, interesting. I just did the

but then I got no stars in the sky. With the Is Always Night set to TRUE here, I can now see the stars.

andgalf… No, you get a moon and stars but having the day night cycle to true means the sky moves and the moon is smaller like the sun always is with no detail. It’s not a fixed big moon.

Dropbox - bigmoon.DayNightStage - Simplify your life stick this on your default and you’ll find your moon easily.


I got curious now, so I went and opened up my space module. What I had apparently done there in my space area was to have all the Environment Settings set to TRUE. Since I haven’t properly tested this yet (even if it looks good when opening up the area) I will wait with that until the day where I have spaceship creatures.

andgalf… All being set to true will make the settings change so unless they’re all the same and on a night setting you’re in trouble in outer space… Where no one can hear you scream !

You probably have the default changed to space style so it looks ok in the toolset, this will all be fine just turn off day night cycle.

Yes, I believe so too. I will deal with that when (if) the time comes though.