Slow vault and slow download

To even search around on the vault it’s taking like 3 mins for the page to load and the downloads of 100mb files says it takes 4 hours. I haven’t had this issue with vault until a few days ago, just assume something screwed up but not a single word on it.

The only problem commonly reported is that the home page is loading very slowly for some. A workaround for that is to use this link instead:

Otherwise, I find pages load quickly. Downloading large files (e.g. 200 Mb) just takes a few seconds.

So it’s likely that there’s an issue with your configuration (or perhaps a recent change to the Vault which your configuration doesn’t like).

Have you tried a different browser? I had to switch to Chrome way back to work around issues here.

Have you tried removing junk files, cleaning the registry etc? I find CCleaner works wonders on Windows, for example.

Maybe @niv can cast more light…

I used Chrome and Firefox and they’re both the same. I’ve ran CCleaner a day or two ago. It just started doing it, not sure why.