SOLVED ->> ToolSet - "System.FormatException" and "JIT Debuging"

Does anyone know this type of “error” that appears when manipulating certain objects in the ToolSet?

“System.FormatException” in a window box?

The objects are all the “pipes” from the “Mystery of Westagate” hak.

I noticed that the problem only appears when I try to add this object in interior areas made with the vanila TileSet that came with the game, but not if I use it in Tileset made by the community like the “Celar Tilset” made by @rjshae for example.fuck.

I usually run into that when there is either a missing mdb file or something is screwy with the placeables 2da file. Have you edited the placeables file recently?

It seems that the problem is in correlation with the system language of my computer (point & comma), because I tried different format and the problem disappears in some cases.

Finally, it’s a combination of your answer with mine. My OS (win_7) being in french (core native) interferes with the NwN2_ToolSet (Canada French, so it uses comma “,” and points “.” to differentiate the digits).
This also causes problems with 2da files.

In short, it is better to have an OS in English (native).

This problem had happened to me in the past when I was building mods for NwN2 on a more regular basis.:face_with_monocle:

I’m curious then what is the workaround (assuming you are staying with the French OS).

Download and install the language packs (MUI so that the core of your operating system is essentially English (it’s easier to do in win_10). You can always have your other software and your keyboard in French for example after that.

1 Like