Sound problem

I have a soundset for a companion that I made using the ssfeditor. I made a custom soundset.2da that I put in the override folder. However, when I used one of the sounds in a conversation, that plays like a cutscene, the companion doesn’t move its mouth. If one uses another recorded line by Obisidian the character moves its mouth accordingly.

I noticed that in my soundset I’m using wav files and Obsidian uses mp3 with 96 kbit, so I changed my sound to that in my audio editor program (I’m using SoundForge for that). That didn’t help however. In fact that particular sound no longer shows up in the toolset. The sound has the same name as before, it’s just that it is an mp3 file. If I open the ssf file in the editor you can’t change the file type there to my knowledge.

Also in the toolset I see that my soundfiles doesn’t have a sound length if you know what I mean. My sound files all have the length 00:00:00 for some odd reason, while for example one of Obsidian’s sounds have, if you take the sound 10_brelaina_0049, the length 00:00:03. I’m under the impression that the sound has to have a length if the character is going to use its mouth. So, how does one fix that? Do you have to do something with a custom tlk file or something? How do you do that? Could someone explain that in an easy way perhaps? I’ve tried downloading the Killer TLK Editor and the TubularFrame, but as of right now I don’t exactly understand those programs. Maybe I’m on the wrong track here? Maybe there’s something else I should do?

In help txt file for the ssf editor it says: “STRREF = the dialog.tlk line number if you want the label to get its string value from that.Enter **** if you just want to stick with the LABEL value and not have to find a suitable STRREF from the default tlk, or create a custom tlk.” Maybe I need a strref? Right now I just use ****

As always, thanks for your time!

I checked Rogue Dao’s Lip Flappers that I am using and noticed they have .fxe files with the same name as their wav files so I thought “Ok, let’s just take one of those files and rename to my file’s name”, but that didn’t work either. I’m quite certain it must have to do with my wav files not showing the length in the toolset.

One really weird thing is that although the Lip Flappers files are wav, in the toolset they say that they are mp3. Maybe somehow the toolset converts the wav files? And if they do, why is not my files for my soundset converted?

I saw here that evidently mp3 files can be renamed wav. Maybe that’s the case here. Tried with saving my sound files as 96kbps mp3, and then renaming it with the Mp3ToBMU program, and now I see the length in the toolset and the sound playing in the game, but still no moving of the mouth despite having copied one of the lipflapper fxe files and renaming it the same as my wav file. Maybe I need to do a tlk file or something…but the lip flapper files have no special tlk file so logically that should not be needed…

Are you using standard heads for the characters that are supposed to talk?

Yes, I think so. I mean the character moves its mouth when using the Rogue Dao’s Lip Flappers sounds. However, I use the Xaltar Replacement Pack aka NWN2 Facelift Pack:

I also found the FXE Generator Tool and thought that maybe now everything will be solved, but unfortunately that program crashes on my computer. I have Windows 7 64 bit and I read on some old post from the old ign vault that that program may not work on 64 bit.

MediaInfo gives comprehensive information about soundfiles.

(it’s not fooled by renamed extensions)

Thanks, but I don’t think that’s much help at the moment. Almost all this info I already get when using SoundForge. I think I just need to get FXE Generator Tool working. Since I have a Win 7 32 at work, and I’m going to work tomorrow, I’ll try installing the generator tool there and try to make a FXE file. Hopefully it’ll work, and hopefully the lips of my character will move if I have a proper FXE file.

I’m guessing the mp3 files used for talking are no different than other game sound. I have a writeup on my blog somewhere on getting custom sound in-game. Tchos told me how to do it iirc.

I managed to get it working.

I was at work today, and there we have computers with Win 7 32 bit. I installed and tested FXE Generator Tool there, but that didn’t work (So apparently this program doesn’t work with Win 7 at all). Then I remembered we have a Win XP computer in a storage room that’s not online or barely used anymore. I installed the FXE Generator Tool there, and there it worked. When I got home and tested it, it worked without any problems in game. The wav, mp3 thing was apparently never an issue. I went with my original wave file, so you don’t have to have a 96 kbps mp3 file, it works with a regular wav file.

Too bad this program doesn’t work with Win 7. At least for me I only get an error when pressing Generate after loading the audio file.

Did you try it in xp compatibility mode?


Yes, I did.

Has anyone else got this program working in Win 7?

I have it working on Win 10 x64. You have to run it as admin, otherwise you’ll be getting an error “access is denied” when pressing Generate (if the program is installed in the Program Files folder). Don’t know about Win 7.

Really weird. I have a laptop with Win 10 64 bit in my kitchen. I tried installing on that one, but I get the same error message as on my main Win 7 computer. Am I using the wrong version or something? (Still, it worked on Win XP)