Spell targeting area of effect has stopped working

I have been playing Tale of a Mage, which I have been enjoying. When I got to chapter 2, I decided to rebuild the character I had with what I had learned about being a Wizard. The result was not what I expected because I still had Conjuration school problems.

I noticed that at the start of Chapter to the spell targeting area of effect was not showing, which I found confusing.

I then decided to delete all the game saves and start Chapter 1 again with a fresh character so I could benefit from what I had learned about wizards.

Chapter 1 no longer shows the spell targeting area of effect even though it did on my first playthrough. I tried validating the install, rebuilding and installing the Mod installation, uninstalling everything except what was required for the Mod and even tried the game on a fresh Steam installation (I use Beamdog’s installation to play).

The spell targeting area of effect works using the same character in a different mod.

Can anyone give me any advice or help to get the spell targeting area of effect working again for Tale of a Mage?

Did you have a newer spells.2da in your development folder? Maybe the module has one in its haks that has not been updated and you have since deleted the updated one from Dev?

Many thanks for responding

I have nothing in my development folder and, as I said, it was working on my first playthrough of chapter 1. Stopped working when I got to chapter 2 using a Leto modified character, which I have now deleted.

My understanding of the feature is that it is based on the new columns in spells.2da. No new columns not targeting feedback. The module is old enough that if it has a spells.2da in its haks it won’t have the added columns. Maybe the haks for chapter 1 did not have spells.2da in them and then one of the ones in chapter 2 has the same name (thus overwriting the ch1 hak) and has spells.2da in it? I think that would explain what you saw. I don’t think it is related to the character at all.

Thanks for the information. A weird thing just happened, I took a ship (an early part of the game) and on the ship the feature started working again.

I wonder if it is tileset related. I can’t think of any other reason and I am sure I read somewhere that something needed to be enabled for the feature to work.

Or, maybe getting your attention was enough to embarrass EE into working again :slight_smile:

I know TOM quite well. This mod (maybe only part two?) has custom made spells, which might cause trouble with the new EE feature. Maybe the new 2da needs to be merged with the 2da of the mod?

@Mmat thanks for responding.

I will see what happens when I get to chapter 2 again. However, in chapter 1 the feature did not work in the cave with the two bears in it. After I got on the ship, it started working again and has continued to do so since.

2da merging is probably beyond my meagre skills for something that it is nice to have but not game breaking.

Ah, I’m already looking. It’s an interesting phenomenon. Could there be a interrelation if the area is in-door?

edit - The spell.2da of both episodes are identical, so if it’s 2da related, both episodes should behave identical.

Same as with feature to allow new weapon feats, the way NWN-EE implemented it prevents it to work as-is in any module without compatibility issues. Merging the 2da and altering its haks would be needed.

It will work only in modules that doesn’t have spells.2da in their hak packs.

Adding the spells.2da from patch 35 into development folder is a terrible idea which might cause all sorts of issues, although in this exact case it might not crash game so I suppose that if you absolutely want to play given module with this feature it is something to consider. You will however at the very least lose all sorts of custom spells that this module might be giving access to you…

The module appears to be bugged kind of. The prelude uses its custom hak with spells.2da, but the main module story doesn’t. So the custom spells of this module are not accessible in fact.

I doubt it was intented to have the access to the custom spells only in prelude so I would classify this as a bug.

Here: a fixed version of the main module that uses the custom hak AND modified hak file that will enable this NWN-EE feature for vanilla spells. I didn’t enable this feature for those few custom spells as I didn’t try them and therefore I don’t know what the indicators should be.

tom_chap1_hak.7z (46.7 KB)
tom_chap1andprelude_2.3_final.7z (1.2 MB)

Of course, I did not add any changes from Community Patch into spells.2da as some peoples might get rash.

Feel free to upload this into original project, I kept the module version at 1.66 so it doesn’t require NWN-EE to be played ofc.

Many thanks for taking time and trouble to do this @Shadooow - very much appreciated.

I noticed that Tale of a Mage, Chapter 1 - The Uvudry Threat Prelude.mod seems to be the same as the original (according to the checksum NIT creates) - is this correct?

Also, given that I am in the midle of Chapter 1, I presume I will not be able to test the changes. Is this correct?

Finally, is the hak used by Chapter 2 as well as chapter 1?

Probably because I extracted it first and then repacked it? I did no changes to prelude module.

Hmm, probably not. I am not 100% sure. You can extract the spells.2da from the hak and put it into override or development folder but do not forget to remove it after you are done with the module.

No idea. I only checked the first chapter.

Many thanks.

Do you think using the hak as a patch hak would work? I will try this approach if the feature stops working later in the game.

I just got back from the Ebony Isle quest and all the commoners are hostile :frowning:

I’m late to the party, but I just wanted to say that incidentally, I’m currently playing the TOM series too. I had advanced to chapter 2 already, when I saw a post on the Steam forums asking how to disable the targeting effect (in general), so I went into my TOM2 savegame to experiment, but found that there was no targeting effect anymore, even though it was toggled on in the menu. I have been wondering about this, too, but didn’t make a thread about it yet. I guess without the Steam forum post I would not have noticed, but I do remember using the targeting effect in chapter 1. Maybe it is specific to this module series only then, which would be a relief.

Yes this confirms my discovery. Chapter1 is missing the ToM_Chap1_Hak hak which adds custom spells and due to which the NWN-EE’s new feature doesn’t work (the old spells.2da in that hak doesn’t have the neccessary values for this to work).

Which is why this new feature is working in Chapter 1, but not working in Prelude and as you now confirmed in Chapter 2.

No because the module is not using that hak.

Are you saying this is related to you overwriting the module with my version? Or you are reporting just another bug in that module? Eitherway I don’t know if overwriting modules can cause that. What I know is that if you kill any NPC of same faction as the commoners in town, then this happens. This is normal and happens all the time on PWs, killable neutral NPCs must have custom faction for this not to happen.

Oh, this would also explain why the custom spell I picked in the prelude during character creation or level up was suddenly gone in chapter 1!

1 Like

No, still using the original since the game was already in progress. I was just having a grumble. I redid the Ebony Isle Fortress and, second time around, did not have the problem. So I guess the mod is very fragile.

It can be also triggered by destroying some placeable that has faction set to commoner. By default every placeable is of hostile faction, but author could have changed that for whatever reason, then destroying the placeable would cause this as well. (If you are not aware of murdering neutral npc).

But yes, you can bet there are numerous issues in the module, this is typical for fan-made stuff. I am willing to fix the issues, but the question is whether I am allowed to replace the files on the vault page. Since that resets download countdown it is probably a bad idea to do anyway and I am not into posting an updated version separately in new project…

Thanks - that makes a lot of sense - I use fireball a lot.