Can anyone explain what may have caused my spell targeting UI to have stopped showing?

Eg: A small circle under the pointer for Summon Creature spell.

The target system works on my wifes computer, and a saved game from her computer tested on my own computer also works fine.

But, a new module with a new party on my PC and the pointer remains a small static casting pointer, but with no “special” targeting UI.

UPDATE: It appears to be related to a single area in further testing, which may mean something specific to that area.

UPDATE: I built a small new area and it definitely appears to be something to do with the specific tileset. Is that possible? Are there any tileset builders who can comment?

Anyone have any ideas?

Would not let me edit the original post, so …

it did’nt stop showing, it’s “under” just like the selection circle of your character.

The ground UI component is hidden under the green part.


Yes, I worked that out as well. But, I suppose my question still stands, in that is there any way that the tileset can be “fixed” easily?

At the moment, I was looking for a way to raise the UI image via SEF editing if possible.

I even put down a slightly raised walkmesh helper placeable, but that did not help.

Drew made placeables which behave as you want I don’t know how he did it. They are somme giant specific placeables for some of our area.


You should try to contact him.


Thanks, I will take a look at this to see if it can be of help then. :+1:

I could find no way to access the SEF. Must be hard-coded.

I have now tried using some placeable objects around the area, but unfortunately it’s still not ideal.

I think it may need the original tileset walk code “lifting” slightly, but I have no idea how to do that. So for now, I’ll just go with it unless someone is able to address it, assuming that is possible.

To me that looks like the ground doesn’t have the ‘Projected Textures’ flag set in the material properties. Is the ground a placeable?


Thanks for taking a look.

No, it’s just a “normal” custom built tileset. i.e. I have not placed any placeables here.

The image shows the standard interior tilset directly next to the custom built sewer one that has the “problem”. I did that to demonstrate the issue.

It’s as if the tileset has its “walkmesh” level set just slightly too low for the PC UI to show up. (Even the walk to circle does not show.)

I think it may have been done because the sewer floor is slightly uneven. However, I think I would rather the PC walk slightly above the floor, and have visible UI if possible.

If you think you can help resolve the floor level, it would be a great help. :slight_smile:

Well then it’s possible the tileset has some issues with the projected texture flag not being set.


Is that something you are able to fix for me?

I don’t know how involved that is. But if it is something you would be willing to look at, I reckon players would appreciate it as much as me. :slightly_smiling_face:

I took a look at that tileset once and decided it wasn’t worth the bother trying to fix. I’d recommend using a different tileset.

1 Like


Ok, thanks for taking a look. :+1:


Okay I had a little time to look back at my old copy of the Tuopon sewer tileset. Examining the tiles with MDBConfig, what I see is there are no parts with an _F or _RF suffix. This is the standard naming convention that tells the game engine “I am a floor part”. Hence, it doesn’t know to automatically turn on the ‘Projected Textures’ flag. To fix it, you would need to use MDBConfig to modify those parts of each tile, set the flag, then save the tile model.

I would suggest an experiment. Create a new interior area, cover part of the ground with the first open floor tile variant, then verify that the projected texture f/x isn’t working. Now open the ‘TL_MG_TUP_XXXX_01.MDB’ model file in MDBConfig. You’ll see multiple parts, but the floor texture (sewerFloor01) is applied to the ‘TL_MG_TUP_XXXX_01d’ part. Now you can try setting the ‘Projected Textures’ flag, saving the model, and adding the modified file to your hak. In theory, following a rebake, the protected texture f/x should now appear.

Does that make sense?

For example:



Excellent! Thanks for this info. That sounds like it is exactly the information I need. :+1:

I did not know I could fix it like this. I will give this a go and let you know …

UPDATE: OK, so I applied the “Projected Textures” on one of the tiles, as in the image below. Started a new module (only the tileset files in the override), but sadly, I still had no “move to” UI. (I had baked it after the alteration as well.)

UPDATE: I found the specific tile you mentioned and after applying the same thing, I have this … As you can see, it appears to resolve the issue in part. There is still a section just slightly too high for the UI. Is there a means of raising the “Projected texture” a fraction? Or anything else I can do to fix it?

With the “Projected Textures” removed again …

It looks like that is using one of the wall textures, so you’ll need to identify that part and tick the flag. (Like I suggested, this tileset really isn’t worth the bother.)

Ed.: Examining the model in Blender, it looks like the part is ‘TL_MG_TUP_XXXX_01c’.

1 Like


Oh, I did not know each part worked with other parts like that. Very well, I will keep searching.

I have already committed to the tileset. Not using it now would set me back more than I would like. If I cannot resolve the issue, I’ll just live with it. :thinking: I have already used other sewer tilesets in module 2, and so wanted this one for a little difference, reflecting different sewer builders.

Thanks! :+1:

I don’t know if this is related to your issues but be warned I used that tileset, spent ages making two sewer areas and then had to scrap them both and remake the areas using a standard tile set. I was not happy and had made bridges, funky water features, a big one way system and added loads of placeables.

The problem started when I play tested it and all the npc’s had real problems ( pc no issues because controlled ) with the walkmesh when a fight started despite it all looking perfect when baked. The real bad areas when all npcs didn’t have a clue which way to move and jumped on the spot or bashed themselves into walls repetitively included the canals in the middle but the rest didn’t work that well either.

Be warned they are cursed tiles and if you do use them then just lay them out and forget everything else, bake and play test with npcs and fights not just a wander with Adaur Harbor because you could waste a lot of time like I did if it goes wrong.


Thanks for the heads up … Perhaps the problems you report have some relation to the points I have raised. I don’t know. I do intend to do plenty of more checks on this area yet, but do take on board what you say as well.

Worse case scenario, I may just have to scrap combat in the area - although I could probably sort something out.

Throw in some cutscenes too because they went a bit weird. It’s a really good looking tileset and the placeable water features it comes with really make a difference but I just couldn’t get it to work and decided enough was enough.

You could just use it as a link to lots of areas if you have to sneak around a city.


Well, in all tests so far, the area has run as expected, apart from the UI issue.

I have one cutscene (so far), which worked OK.

Combat to any length still needs testing, but I certainly intend to test this, like I always do. :wink: