Summoning portal and destroyng it!

The docs are misleading, but yes, it does work.

@Dragonqueeny - You can download my little test module here to see how I did it:

i checked it out. the bookcase was not spawning so I could not place the books inside

Oh, so you’ve got it working now? Or am I misinterpreting what you say?

yes unfortunately you arwe. I cannot seem to get that to work either

But did you check my testmodule? Everything works there…I don’t understand.

By the way, what do you mean by “The bookcase was not spawning”? I do no spawning of a bookcase in my testmodule so I have no clue what you’re talking about. Please explain in detail what’s going on.

Okay I see where it confuses me. You used the storage item also the deposit item. I was looking for where to place the books really

bHasBook1 = TRUE; < - Is this per chance the resref of the item?

That should be the tag, as per GetTag(oItem);

Eh…now I’m confused. What do you mean by that?

I created three custom items. Three books. I placed them in the inventory of the bookcase (I believe it was a bookcase).


It works, so I will see how to make it work with mines, probably gotta make another set of new items with said resref to see if it works since that might be the case

Eh? Ok, so it works now…eh…good.

I think I figured it out at least as the resref is different from my own items I created that prevented it from spawning

Or that is my assumption

So the bookcase where you place the books… That placeable is spawned somewhere into an area?

When it comes to objects I have a habit of always using the same for resref and tag and so on, sinceI find that convenient. Then I don’t have to think about if a script calls for resref or tag…I can see the downside to that though, that you can make a lot more objects in the world with different tags and the same resref to save space in the module directory I guess (Oh, maybe NWN1 doesn’t have module directory…ah, anyway).

no, the confusion transpired cause you put it in the same place you were supposed to deposit it. I was expecting a second chest or bookcase to deposit them in but the resrefs should be the issue to my little issue.

So…Do I understand you correctly now…

You wanted a chest for example, where the books where initially, then the PC takes them up and put them in the bookcase? And since I had already put the books in the bookcase to begin with, that’s why it was confusing?

I did nto wanted it in a chest. it was confusing cause they were already in a bookcase. not an issue though! I THIIIIINK I figured it out :slight_smile:


Edit: I tested with putting the books on the ground instead and letting the PC pick them up and then put them in the bookcase, and it worked just fine that too. Without them being in the bookcase, nothing happened, as it should be, and when putting all four there, the portal appeared and you could teleport.

You get a look on the ítem tags in the original function. Tags don’t support empty spaces.

If you look after ítem with tag “book_n tag” it won’t work. Check ítem tags are right.

I got it figured out, it does not correspond to the tag if the resref is not installed book1, book2, booki3, etc