Swordflight Chapter 1 (port to NWN2)

This is a port of the highly acclaimed NWN1 module, Swordflight ch1 by @rogueknight333.

I’ve been working on this on and off for the last 6 months and I think it’s ready for some testing. If anyone is interested in giving it a try, please report any bugs here.

I tried to keep it as close as possible to the NWN1 version, but of course, some things needed to be changed in order to fit the NWN2 engine. Many of the scripts are still the same as they still work. I also used the same blueprints, although, they needed to be adjusted a bit for NWN2. All of the areas had to be rebuilt from scratch, but I must say they look pretty good for a noob builder such as myself.
There is one companion, a bard, that will join you near the beginning of the adventure. She is completely controllable.
I tested this with a paladin, cleric, ranger, and rogue. Fighter types fared the best in the beginning. I imagine arcane PCs will have a difficult time at the beginning.
Conversation skills are a must-have.
Also save a lot. You will likely die often as this was designed to be quite challenging (like the NWN1 version). There is a very unique respawn death system in this mod just like the NWN1 version. It’s actually part of the story, so don’t be frustrated if you die/respawn. Although, there is a small XP penalty for respawning.
I added some crafting opportunities, although, it is limited. Crafting traps is very useful!
Enjoy :slight_smile:


Argh!!! I’m probably gone through the weekend, possibly into next week.

I will absolutely give this a run as soon as things quiet down in a week or so.

1 Like

I will take this as a compliment. Any reason you are distributing it by dropbox rather than uploading it to the vault?


I want some folks to test it first as I’m sure there are some bugs. Once any bugs are sorted, I’ll post it to the vault.


I’m absolutely new in installing 3rd-party modules in NWN2. Never did it. Maybe it’s time to start … How to get this thing installed? Just drop the files in the same folders on the NWN2 user directory?

I wonder why there are so many files which look like palette blueprints and scripts. Why is that?

1 Like

Yep, just extract it to your user/Neverwinter Nights 2 directory. Then start a new campaign.
I’m using the files from the original NWN1 module. Most of them I have edited. Some of them are no longer in use. Also, I have added some new files from the cornucopia, tileset project and creature compilation pack.

1 Like

Seriously ? Some of your scripts are holding my modules together and have done for years !

But congratulations on making a whole mod, it’s nice to see your characters roaming around in an area you made isn’t it… Until you spot the floating tree that you didn’t sink into the ground, the house on the slope that has it’s porch magically supported by air, the supposedly small dip in the road that looks like a bomb crater or the grass that really shouldn’t be where it is !

When I made my first module ( Serene ) I didn’t know how to delete anything ( placeables, npcs etc. ) and I made a big hole in a corner and dumped them all in it, causing an environmental disaster. I figured that couldn’t be right and had to run to the old forums to be informed I had a delete button on my keyboard :woozy_face:


Wow, that’s really a great conversion.

I got as far as to the spot where the caravan raid should be happen. There the plot breaks. Shouldn’t the merchant be somewhere? I didn’t find him. However, there is no raid. everybody is just standing around. I left the area to the camp (which shouldn’t be possible right now) and returned. Now the wagons are burning and the cleric from the camp appears. Anybody else is still standing in place, alive.


  • The PC should get a weapon. I believe this is a fault of the engine, that newly created PC’s don’t get a weapon. Just a butterknife would be nice. Suggestion: Allow that the PC loots the first weaponrack next to the staircase in the basement without penalty. There are two torches and a handaxe.
  • 550 Gold for the ratjob is a bit high.

Hey travus!

After all the help you have given me, the least I can do is give this a spin. I’ll look at getting started next week!


Hi Travus, I just started a playtest run tonight. So far I think I am just at the end of the portion that is in the inn. I am enjoying it so far and not seeing any bugs. I do think some of the quest rewards are a bit high for level 1 but that is a stylistic choice many go with and since this is an adaptation likely not up to you anyway.

I am not sure if it is intentional but while taking things from containers will cause an alignment hit (unless you are dumpster diving), picking pockets does not.

1 Like

@Mmat, just so I’m clear, you have Zarala in the party and then you spoke to Saman in the inn where he sends you to the caravan. But when you get to the caravan area, Saman is not there and the cutscene did not start? Is that right?

@Quixal & @Mmat, WRT the rewards, equipment and alignment shifts - Yep a lot of the scripts and rewards are set-up like that in the NWN1 version. I don’t want to stray too far from what @rogueknight333 built. But I will confirm that I didn’t screw something up and change it by mistake.

1 Like

I can confirm Mmat’s experience with the caravan situation. After speaking with Saman to leave the inn, we end up in a camp with no Saman and no cutscene.

Edit: Oh and yes, I have Zarala in the party.

1 Like

Extract these files into your Swordflight Campaign folder and then reload to a point before Saman takes you to the caravan. You should immediately start into a cutscene at the caravan area with Saman and some other caravan folks after speaking with Saman in the inn.

Right. I have Zalara in my “party” (otherwise it shouldn’t be possible to join the caravan) and Saman sends me direct to the raid location. The cutscrene, where the PC is supposed to die, doesn’t fire. I think I still have the savegame so I will try again later.

Question to the NWN2 experts:How can I work with the mod if it isn’t just a mod-file but just a collection of files in the subdirectory?

1 Like

In the toolset, select “Open Directory” and navigate to the “modules” folder. You should be able to select and use the module’s directory just as you would a .mod file.

1 Like

Ah, I see, you already fixed it …

1 Like

The fix worked. Found one bug in the bandit camp. The gnome wizard bandit’s hidden chest does not open to Gedlee’s electric arc. On further mucking about with spells starting with electrical ones, I was able to open the chest with a lightning bolt.


Works well.

1 Like

Found a bit of time today to make a start.

I have played up to the start of the ruin with the spiders. No showstoppers and no real bugs to speak of, good stuff!

I had no problems with the merchant caravan raid cutscene; I did install the patch right after installing the campaign.

I was surprised that you need to have full completion of multiple quests to progress past the Inn opening area. I had one of the required quests incomplete and didn’t realize full completion was required until I opened the module in the toolset to figure out how it all fits together. I can’t recall how the NWN1 version worked, but if that’s how it was, then it can only be a faithful adaptation :wink:

Just one bug, if it can even be called that. I think it’s a NWN2 issue though - Roigo the merchant at the Oghma camp sells torches - these torches are deactivated. Not a biggie, there’s always Zalara to cast light…

It’s well put together. Tough, but the fun kind of tough, which isn’t easy to achieve :slight_smile:


@Kevlar, good catch! I knew that stacking torches will break them. But I didn’t know that setting them to infinite in a store will also break them. I’m always learning new stuff :slight_smile: I’ll have an updated store blueprint in the final.

@Quixal, I updated the patch file for the Electric Loop spell on the magic chest. If you still have a save before casting on the chest, could you extract the two ‘x2_s0_elecloop’ files to your campaign folder and cast the spell on the chest? It should now work just being in the AOE of the spell now, too.