System.formatexception error - need to worry?


#1

I tried exporting three areas to be used in my module from the Witsend prefab by rjshae (really beautiful areas by the way) https://neverwintervault.org/project/nwn2/prefab/area/witsend , but when exporting as an erf I got the error:

System.FormatException: Input string was not in correct format…

I saw an old thread where something similar was adressed:
https://neverwintervault.org/forums/neverwinter-nights-2/nwn2-toolset/cant-get-placeables-bckii-work

However, when importing the erf and opening the areas in the toolset in my mod, and then trying it out in game, everything seems to be working just fine. Do I need to worry? Should I not be using this? Will there be problems later on perhaps?


#2

“format” here means type (string, int, float, etc)

It’s likely that the erf-builder expected, eg, an int but the value (that threw the exception) does not convert to an int. This could happen if the value is “3j” (has a letter or other non-numerical value in it)

So by the time the object gets into your module, it probly has a default value assigned, say “0” in this example.

So something might not work right – could be anything from a placeable’s Fade setting to … whatever. But the default could be acceptable and no one’d ever notice it,

 
 
( it’d be nice to track down the error but it might be a needle-in-haystack thing )


#3

Do they use custom tileset? importing erfs containing a tileset that’s not in the module will cause similar errors.


#4

Hmmm, you may be on to something kamal. I checked again and when exporting the three areas one by one, only the the third one, which is an interior area, gets the error message.

I’m trying to look at the tiles that are used but I can’t see if it’s a custom tileset. It seems to be using the Estate tiles (EstateCeiling01, EstateFloor02, EstateWall02), and it looks identical when in my module, so I don’t think (but I’m not sure here) it’s using a custom tileset.

When looking through blueprints it’s so obvious what is custom for the module and not, but it’s not as clear when looking at tiles, or maybe you can see that someway…

Since it’s only this one area, I think I’ll go for it and cross my fingers, and hope that I have nothing to worry about.

It is odd though, that the error only occurs when exporting from the Witsend prefab module, and not when importing the erf into mine.


#5

I’ve stripped out the modest hak pack content as unnecessary.

at least from rjshae’s description it sounds like he used custom content. perhaps something slipped off the radar.


#6

Yes, could be, I suppose.


#7

I’m fairly sure I didn’t use any custom content on that prefab.


#8

Ah, then it must be something else. Thank you for replying, rjshae! I’ll go on using your prefab areas and hope it’ll not cause any problems. By the way, the area that gave me the error when exporting is: 1300_xylastria’s_tower


#9

Hmm yes, I get the same error. It seems to be an issue with the area itself, because if I just strip it down to a single area with no other objects, it still gives the error on export.


#10

Those three errors are being caused by three unique placeables (paintings). They are currently set to environmental objects. The models of those particular objects appear to be missing as you can’t see them.
The tags of the objects are:
plc_mc_painting213
plc_mc_painting215
plc_mc_painting222

Deleting those three objects will allow an export without errors.


#11

Ah, nice! Excellent travus! I’ll try deleting those and see if it works.

Edit: You were absolutely right, travus! It works exporting without errors now. How did you manage to find that out? Great detective work there!

Thanks for the replies and help, you guys!