The OCD's arsenal

So a glitch occurred the other night where after I was done levelling up Bishop, I got a journal update… for The Wizard’s Arsenal. The one quest that upon completion disappears into nothing appeared out of nowhere in my journal. This isn’t even the first time. A couple days ago, I found it lying around in my journal for no reason, even though it was in the middle of Act 2. Fortunately, I fixed it by going into Tarmas’ house, ‘completing’ the quest.

This time, however, I can’t do the same, because I’m in Arvahn. So I can’t go back to West Harbor.

OCD problems intensifying

i believe there’s a fix for this in Nwn2Fixes

but it works only on a new game and won’t correct the bug once it’s already happened in your current game …

I remember the discussion; it’s related to the fact that the flag is set onEnter but you can enter before getting the quest, so Tormas resets the flag and you can’t advance it again.

And yes, it got fixed.

1 Like

But is there another way to complete it or even remove it from the journal?

I honestly don’t know if this will do it or not, but you could try traveling to West Harbor and then using the console command rs 11_a_tarmas_center

1 Like

That’s the name of the location, then? I presume I can go back home using the name of the Crossroad Keep location, too?

ready to compile a script?

Copy the code below to a new textfile in /Override and call it “ga_deletequest.nss”. [edit: add extension]

in the toolset goto File->OpenConversation/Script …

open “ga_deletequest”

click the Compile button and check the bottom of the window for success.

// 'ga_deletequest'
/*
    Dialog script (can also be run from the console etc on OBJECT_SELF).

    Removes 'sQuestTag' from the Party Journal.
*/
// kevL 2019.2.23

void main(string sQuestTag)
{
    object oPc = GetPCSpeaker();
    if (!GetIsObjectValid(oPc))
        oPc = OBJECT_SELF;

    RemoveJournalQuestEntry(sQuestTag, oPc);
}

Then load your save. It doesn’t matter where your party is. Open the console and run

`
debugmode 1
rs ga_deletequest("11_tarmas_house")
debugmode 0
`

If you want, check out my party DM tool. It has an operation that should allow a party to jump around a module/campaign (as long as you know the module-name and/or waypoint-tag in advance)

I couldn’t go past opening the file, because the toolset can’t find it. Or is it because I have the game open?

probly not – Edit: but the game may have to be closed and re-loaded from desktop after adding a resource … though a simple area transition usually catches a re-compiled script

try closing and re-opening the toolset …

oh, sorry : the filename should be

ga_deletequest.nss

.nss is the extension for NwScripts (and after compiling, its binary file should appear in the same directory and have extension .ncs)

Still doesn’t exist.

I just realized I was supposed to add an extension to the textfile, and I’m an idiot.

And it worked. Thank the gods… My OCD can finally relax. Thanks.

1 Like