The Tale of Fur and Frost - a Single Player Outdoors Adventure - is now released!

IMPORTANT UPDATE: VERSION 1.0 CAME WITH THE STARTING POINT IN THE WRONG AREA! PLEASE DOWNLOAD V.1.1 FOR THE CORRECT SEQUENCE OF EVENTS!

Hey everyone!

With equal parts excitement and trepidation I hereby announce that my first ever NWN1 module has been released!

You can get it from the Vault right here.

The Tale of Fur and Frost is a small Single Player adventure module that aims to give you the experience of travelling though the great outdoors, relying on your skills and fortitude (and possibly on your one companion) to survive in the harsh winter and save an old forest from a supernatural disaster.

While the adventure has strong druidic themes, all classes (and races, alignments and genders) are available, and your PC need not necessarily be a treehugger.

This is my first ever project of this kind and I am interested in any and all feedback, but I also just hope to offer a few hours of fun.
Good Hunting!

6 Likes

Well you have your first down load. I will let you know how I like it soon.

1 Like

IMPORTANT UPDATE: VERSION 1.0 CAME WITH THE STARTING POINT IN THE WRONG AREA! PLEASE DOWNLOAD V.1.1 FOR THE CORRECT SEQUENCE OF EVENTS!

(Also please forgive me for this idiotic mistake)

2 Likes

Now that you’ve moved the starting point, I’ve been having a much more enjoyable time with the module. Thus far, the writing’s been nice, the areas have been good, and there’s been quite a bit of challenging to some of the encounters, but I’ve hit a bit of a snag with the “Missing in Action” quest that, had the module not made an Auto-Save a while earlier, might have just killed my playthrough. I’ll put that in a spoiler below as to not spoil the encounter for others and to not clutter the thread, as unfortunately I’m rather long-winded when I post on any forum, but I’m at a loss as to what to do outside of reload the auto-save and not do the side quest, which is something I only want to do if necessary.

Spoilers

I got along to doing the “Missing in Action” quest a while later than I probably should have, as I didn’t exactly realize exactly where the game wanted me to go, but once I spent more time just looking for where I was meant to go, I found the tracks and discovered the ancient shrine that had I had originally been met with in version 1.0. I figured that now, me being level 7 and having better gear instead of being level 1 with just a sickle, I would have no trouble with these blasted ghosts. Unfortunately, it doesn’t appear that the Spectre leading them cannot permanently die. He does die: he hits the ground, it says he’s dead, and I get nearly 400 XP, but he almost immediately resurrects. I figured that if I killed his Shadow Blights this problem would be solved, but unfortunately it was not, as he still refused to die. He ran out of spells he was willing to use at melee range and was left to blindly attack me, which was horribly ineffective and I had killed him enough times to level up to 8. I figured that the key to victory had something to do with the Sacred Tree, but from smacking it with a sickle to hitting it with a firebomb, I’ve learned the thing is indestructible. I didn’t want to kill it anyway, I’m playing a Druid and killing the tree seems like the last thing I’d want to do, but it was the only thing I could think of. I would leave the area, which is normally a good answer to encountering enemies far beyond your pay grade, but there isn’t an exit. The tree can be talked to, but it says I can’t do that while in combat. I can talk to the ranger, but he only says “We can’t let those ghosts have the temple!” or something along those lines. Am I missing something here, or are my suspicions that the fight bugged out correct?

EDIT: A detail I forgot to include is that the Spectre revives in a manner similar to the Henchmen in the OC, in that a special effect plays on him and he moves to a point where he revives, namely in front of the shrine. I imagine that this part is intentional, but I’m still unsure how I’m supposed to kill him. Also, if it is just me missing some crucial detail, I still don’t think you should be able to use him to grind for experience like you presently can.

Okay, this is the weirdest shit.
And to think that the whole rigmarole with the wrong starting point was that the last thing I did was test the spectre encounter to make sure it was all right.

For crying out loud.

It does seem like you’ll have to forgo the sidequest, because somehow, the spectre from the temple got a henchman script set (go figure) and can’t even be killed by the console now. I’ve no idea how this happened, it was all nice and working!

I’m sorry this is such a screwup. I’ll do better next time, I swear.

Oh and as for being stuck in places you can’t get out of - this time, it’s due to my mistake, but there is one place where you may get stuck on purpose if your search skill is low, so before that happens, you may want to talk to Liam again once he’s back in the stone circle and ask him for more help.

2 Likes

Don’t worry, like I said the module has been good so far, and I thank you for getting back to me so quickly. With any new module, no matter how good, you can expect its launch to have some quirks and abnormalities. At this point, I think these ghosts are just trying to sabotage you. :wink:

But now its time for me to be angry at myself. I already had the item from Liam, but in my attempts to escape I tried to use it while my companions were fighting the Spectre. Good news, you can’t gimp it like the Stone of Recall, as it can’t be used in combat. Bad news, it only has one use per day, and I can’t rest in the area. Unfortunately, in my hubris I saved after this attempt, even though I could simply run away from the ghost and kill him when his respawn point was out of sight. In short: I’m a moron. Why I thought it was a good idea to save after I discovered what appeared to be a bug, I can’t tell you. Oh well, at least I’ll get my firebomb back.

1 Like