The Umbral Abyss (Major Update)

It’s here! 5 years since release, this is the biggest update the campaign has received to date. It incorporates many of the improvements seen in The Indanthrine Prince along with hundreds of fixes, changes and improvements. Completing this has opened up the path to the final part of the trilogy, which is now receiving more of my attention. Many thanks to @travus for his assistance with the update.

I made a short trailer.

Headline from the vault entry.

MIDDLE EARTH MEETS D&D

The sequel to Untold Tales of Tolkien: The Indanthrine Prince (2013, Updated 2020). This campaign is the second in a planned trilogy. The Untold Tales series are story driven, action adventure role-playing games set in an adaptation of Middle Earth, telling new, untold tales. The Umbral Abyss boasts gameplay in the region of 60 hours and is designed for characters of level 12-20 .

Whether it was revenge or justice you served to those who attacked your home and murdered your friends and loved ones - Fairfields had been avenged. The savage Maltok was slain by your hand and the mysterious Cerulean Dawn was reduced to ashes. The price of this victory was dear. Your father-like mentor, Thorburn was lost in the daring assault and the enigmatic Indanthrine Prince fled the blazing scene. Nonetheless, a great evil had been stopped, unable to strike at those close to you again.

The long journey home from Rhun barely began before a swarm of unknown Easterlings detained your company and declared that you were to be their prisoners. You have been held captive in the Easterling city of Yahmul Balotz for the last year. Separated from your companions, you have been interrogated repeatedly about your business in their kingdom and, worryingly, the preparedness of Rhovanion for war. How much more of this can you take? War is coming to destroy all you cherish!

The time for heroes has come to Rhovanion. Indeed, an Easterling King has succeeded in uniting some of the most powerful tribes for one almighty assault upon Dale, the jewel of Rhovanion. Spurred on by agents of Sauron, including the infamous Hand
of Sauron himself, the situation is grim indeed. These agents erode the strength of Dale from within and the city risks losing it’s head before the real battle has even begun.

But there is always hope. Allies of Dale are on the cusp of launching a grand expedition to reclaim a lost city, deep within the northern mountains, wherein there is said to be artifacts of immense power. The adventure carries great risk, for this city has a dark, horrific past. Nobody writes of the terrors that lurk in the deep umbral darkness of Middle Earth - maybe it’s best it stays that way.

From humble beginnings, some now call you a hero. Be that hero. Defend Rhovanion and be it’s deliverance - or die in the attempt.

A story driven, single player, action adventure campaign (select from up to 7 controllable companions)
For characters who have completed The Indanthrine Prince, progressing to level 20*
Game length in excess of 40 hours

  • = Alternatively, new characters will be given the experience for 12th level.
10 Likes

Bug Report

  1. When I try to learn Tier I potions, the game says I already have. In fact I only have healing potions learned. It does allow me to learn Tier II potions.

  2. I tried to make a Celebrang Shield at Emeline’s but the output was a High Steel Shield. Components were correct and the the Celebrang Shield skill is in the book.

  3. I notice I still have the Action List Overflow issue in the Blue Maiden. It does not seem to have affected anything game-wise so far.

That’s all so far.

1 Like

Thanks for reporting these. I will be making another update for UA somewhere in the future. I’ll be sure to look at this. I see you are on UA already, I hope IP went well?

1 Like

It was almost flawless.
I did not get the quest to look for the Esgaroth innkeeper’s missing wine. I assumed that quest had been deleted. When I found the wine, the quest got added to my journal but I could not get the innkeeper to take it so I just put it in his storeroom.

I finished as a Ranger 11/Conjuror 1 and ready to transition to Arcane Archer in UA. With all the enemies that have natural DR, the few extra points of damage really make a difference in the effectiveness of archery. The addition of significant arcane magic opens up lots of new tactical possibilities.

I’m having a blast! (Pun intended :rofl:)

1 Like

Action List Overflow Bug


I’m stuck! Here is what I have so far:

  • Currently doing the Lowlifes quest.
  • Defeated the two Draugar in the Old City Ruins and looted the corpses.
  • Game continues to ‘apply damage’ to the now vanished Draugar corpses.
  • Jamot does not revive as the game treats combat as still in progress.
  • Resting does not clear the error.
  • Transition to a new area does not clear the error.
  • Exit and restart game does not clear the error.

Link to save game - https://www.dropbox.com/s/zeigmiqzb0fnnq0/000261%20-%20Action%20List%20Overflow.7z?dl=0

1 Like

The ongoing damage thing is weird. Not sure what to do with that. Although the creatures are rendered script hidden when they “shift” into other creatures, when they die, er… they die! Very strange. Maybe Jamot is taking wounding damage despite being dead, though im sure the game would have removed this.

The 2 Draugaur, however, are not the main encounter. Consider them a mini-boss. There is another encounter in this area which will advance the story.

To get the Easterling off his arse and being more useful, a quick way around this for now would be to spawn in some raise dead scrolls.

CreateItem nw_it_spdvscr501

I’ll take a look at your save shortly.

Glad IP went well. I think a conditional (has spoken to innkeeper) on picking up the wine to add the journal entry should do the trick.

2 Likes

It may be hard to see in the shots I uploaded but it’s Draugar that are still taking damage despite having decayed after I looted them.

My main concern is that it’s still happening after I transition to a new area which could be game breaking at the next major encounter.

Since I just repaired my telescope, the weather has turned to crap so I may try to replay this tonight and see what happens.

1 Like

if you’re looping over creatures and applying damage to critters, you might have to add a condition: if(!scripthidden)

that is, I don’t believe that scripthidden renders creatures completely/totally/utterly invulnerable … they are after all still valid objects in the game,

1 Like

Thanks both. This didn’t come up in any tests. @travus has played a few times too so would be interested to know if this has ever happened to him.

I didn’t use a loop in the scripts for this encounter, but perhaps applying plot to any creature being hidden and unplot when unhidden may help. I’ll check over the corpse options for the creatures too.

2 Likes

I never had that issue in all of my playthroughs. It looks like one of those bugs that only happens in the rarest of circumstances. But, it’s certainly a bug that needs to be looked at as it’s potentially game breaking.
With regard to the Action Overflow in the debug - I don’t think that’s related to the hidden Draugar taking damage. I’m pretty sure that overflow is just a debug message coming from one if the custom AI scripts on the townspeople. It’s certainly annoying to see those messages when in debugmode, though.
I don’t have UA installed at the moment but I can take a closer look later to throw my 2 cents into the discussion.

1 Like

Hey, did you end up retrying? If so, did this happen again?

I concur. I’ve seen a few of these in several campaigns, and only in some areas, but never have they been a warning of a coming CTD.

That’s for sure! Especially when you’re trying to see the value of a variable, but can’t read anything because there are so many messages that the variable data is scrolled out of the chat box.

No, we opened the pool instead so now I have to get that cleaned up. Going to be a busy week.

Not to worry. Let me know when you get back into it :slight_smile:

1 Like

I replayed last night from an early save and got through the fight without further issue.

The ActionListOverflow issue still persists however.

1 Like

Excellent news!

I will continue to probe and try to reproduce the problem.

The action overflow will be related to commoner routine scripts. Not a major problem, but indeed annoying. This can be looked at in a future update.

Enjoy the long road ahead! Save often!

1 Like

Potential Bugs:

  • Marie (the Seamstress?) fails to spawn.

  • I cannot repair Celebrang Weapons even though I have the recipe to create them. That seems backwards.

I tried again to Learn Tier I potions but the game says I already know them. They do not appear in my books. I have learned Tier II potions. Is it possible that leaning them out of order caused the issue?

Thanks. After a quick check…

Marie was using a commoner behaviour for merchants, whereby she “goes home” at night. As we are having action list overflow issues, I wonder if this is preventing her from going/coming back. I have disabled this script anyway.

There are no repair recipes, save for the introduction in chapter 1. All you need is the repair hammer. The repair script contains entries for some specific items you come across, which can be repaired. Chances are, there may be an item or two that I was remiss to add to the script. On the list in Celebrang are; Rusted Celebrang Greataxe, Notched Celebrang Halberd and Blunt Celebrang Shortsword.

I can’t find any issues with the learning sequence for potions. Both use a different variable for tracking, so it is possible to learn tier 2 before tier 1.

1 Like

Update on the repairing Celebrang weapons. I tried again with the short sword. The error message I get is: “You do not posses the skill to repair this weapon.”
I use Crispin for craft armor and craft weapon. His skill in both is 19, boosted to 23 with Lyndsay’s buffs.

Separately, there are two Celebrang Ingot blueprints. One sells for 248 and the other for 22gp in Strobridge’s store. I tried both for the repair but neither worked.

There are also duplicate blueprints for High Steel and Celebrang arrows and bolts. One set of each with the old +2/+3 stats and one set with the new +4/+6 stats. It looks like the older ones cost more in-store than the new ones although I did not check every merchant.

Just settled things with Galen and Cormac and heading to Mirkwood next time I play.

1 Like

Back from Mirkwood and doing more crafting.

Issues: The road area South of Dale may not have the correct area settings. The party’s Rangers have the Camouflage feat and should be moving at speed outdoors even when in Stealthy mode. Instead, they slow just like other characters.

Tried to do a Celebrang Shield in the Dwarf forging area in Erebor but it still yields a High Steel Shield. Must be a typo in the script.

I was finally able to repair the damaged Celebrang weapons. Crispin now has craft Armor/Weapons skills of 20 before buffs are applied. Nothing else changed.

I gave up on crafting ammo. Have not found or probably just missed out on carpentry benches or ammo molds and the high steel and celebrang components the party has been toting about would not yield enough to resupply a single character for even one quest. Ammo has been plentiful enough for the two characters that depend on ranged combat. I am finally realizing my goal of playing an Arcane Archer and still have enough ammo with enough to spare for quests involving Faenwen.

I don’t see any way to make projectile crafting useful without introducing more semi finished components, especially wooden arrow shafts, in the merchant inventories. In particular, one would expect Elven merchants to have more raw wood and planks for sale and to be engaged in working these materials.

Separately, Dale seems to lack the customary ‘shady’ merchant who sells rogue gear. While Jammot has decent trap setting skills, the only kits he’s been able to aquire are by using the Recover Trap option with the attendant risks to the party. I’ve accumulated about a dozen which should come in handy at the battle of Gorion’s Gate.

An alternative to a Rogue merchant might be to have our talkative Ranger friend in Dale sell trapping supplies as part of his conversation tree. He might have other wilderness survival gear as well to make him more convincing as other than an odd conversation on the street.

One other crafting related issue, no hides in creature drops. I’ve seen only one or two sold by merchants but I’ve probably killed enough wargs to carpet the King’s bed chambers already. Crispin has two leather working knives and nothing to cure or strip. Q: Is there tannery I missed?

2 Likes