Tlk merging question: Anyone know how to fix this issue?


#1

So im trying to merge a few new classes in but im having alot of difficulty on this one.

I had a look at the “codi_new__prestige_class__tutorial” and learned a fair amount but what I don’t understand is how to get the new classes feats to show up. Is it possible to get new class feats to read a new line in the 2da or tlk if i move them?

they show up as this in game

this is what the tlk shows and as you can see… my philosopher class overrides it, is there a way to fix it without dumping the new class?


#2

does anyone here know or someone who could help?


#3

What do you have listed as the FEAT column entry for your new feats? Yes, you can move them. The FEAT column points to strref it will use there I believe. Just change that number to where you move the names in the tlk table (the full number… row# + 16777216).


#4

Well not sure what I’m doing wrong but i made it much worse!

Ive tried adding the lines to a new one, but the Dialog.tlk overrides it, so i moved to a line that wasnt in the dialog.tlk and it shows up as a “…” or blank so i decided to leave the Occultist lines where it was in its original state and moved the Philosopher and Noble classes to another line and i get this now

The blank one and the the Incantation class ones are suppose to be the Noble, Smart and philosopher classes


#5

Just to reiterate though I am doing everything not all at once i take it in small bits like editing the class.2da columns with the .tlk to see if anything changes.

So far I’m having no success and have resorted to looking at how other prc content creators did theirs (IE the Prc consortium tlk) but what i’m seeing doesnt make any sense. Their class lines somehow override the dialog.tlk so now i’m at a loss as to how this is done, i figured it would be simple straight forward and i feel like im really close to getting this finished!


#6

The lines in dialog.tlk are numbered exactly as you would use them in the 2da (1 == 1, 100 == 100 etc). You should not be modifying dialog.tlk I don’t think. You should have a custom module .tlk file. In such a file the line numbers start at 0 but to access them you need to add 16777216 to get the number you use in the 2da (1 == 16777217, 100 == 16777316 etc)

What do you have in the FEAT column for your new feat (shown in the picture)? And what row in your custom .tlk file has the string you want to use?


#7

@Wall3t - the very first thing you need to do is to open up the “Occultist tlk” spreadsheet and create a new tab for each of the other classes you are trying to merge, as well as a “merged” tab. Merging tlk files is a tedious and extremely detailed oriented task, which is why I created the spreadsheet. Documenting the before and after changes in the new custom tlk and all of the 2da files is critical for your success and your sanity. :grinning:

Only after you populate your “merged” tab with before and after entries, can you safely make all the changes.

The hardest part is documenting the “before” since very few projects here on the vault have done that.


#8

There’s also such a huge space of rows available in the custom tlk file range that it’s pretty easy to pick an area that is unused. Just don’t start at 0 every time :slight_smile: Then there is less conflict as well.

Whatever you need to do to get the numbers right but really that’s all it is. Put the right number in the right place… if it’s not working then you did not put the right number in the right place…


#9

@meaglyn So by what youre saying what I have been doing should have worked… yet it doesn’t, and i’ll show you what its doing…

This here is the noble class as listed in the class.2da you can see where i have it highlighted that it corresponds to the tlk columns exact new location

Here is its new column, it does not override or change anything it was a completely blank space. Nothing has changed in how i have done this. You can also see that I do not use the dialog.tlk it is my own and have always used my own.

My numbers ought to match up with the correct number, which checking on it… they do so it should work!


This… is the final result now… either I’m doing something wrong or this game is just busted AF lol :joy:


#10

If it comes down to it… may have to do this in 1.69 and see if i can get a different result, otherwise im at an entire loss as to what i am doing wrong.


#11

In the 2da, references to a custom talk file need to have the line number offset by 16777216. Currently, you’re pointing at the OC talk file.


#12

Yes… you are not using the right numbers. As @Proleric said (and I said earlier) the numbers in the custom tlk file need to have 16777216 added to them to get the number you use in the 2da entries. Look at the numbers in the lines for Smart and Philosopher in your screenshot for example.


#13

oh i dont care about the smart or philosopher were just focusing on one for the time being then moving on to the others. im focusing on getting noble to work first guys then we can move on to the others :wink:


#14

I just meant to compare the numbers used for those entries in the 2da to what you have put in for your nobles and see if anything stands out as a glaring difference. I certainly don’t care about smart or philosopher either…


#15

I wouldnt think so but i really dont know how those even work at this point if the column lines dont even exist yet they still show up in the game as if they were there all along.


#16

I’ll try once more…
In the classes.2da file you posted above there is a line for smart and line for philosopher, 2 and 4 lines below the one you highlighted. Look at the numbers in the 3rd col, NAME, and notice the numbers there.
16777233 and 16777225. Taking the first one, if you subtract 16777216 from that you get 17. So in the original custom tlk file at row 17 will be “Smart”. For your noble entry you have the string at 191035, so adding 16777216 to that you get 16968251. So try putting that in for your class NAME.

Like I said, you have to put the right number in the right place. So far in what you have shown you are not putting in the right number…


#17

well that did fix it, im sort of a visual learner so the way you explained it made much more sense than before for whatever reason. anyways i guess that will be it then thanks for the help


#18

Excellent! Right number in the right place :slight_smile:

Once you see that it’s pretty easy.

I think (but I only used it once so I might be wrong) there is a way to make the TLKEditor you are using show the numbers in the +16777216 format. Someone who uses that tool may be able to help if you can’t find it.


#19

Which is one of the reasons I created that spreadsheet that comes with the Occultist. The spreadsheet automatically does the offset for you.


#20

whatever-you-say-fjgg7l