Toolset Area List: blanks?

'Morning, all! Hope the quarantines are treating you well!

I have a wonder. Sometimes, sometimes, when utilizing a customized .set file in a hakpak, that particular set does not appear in the area list for creating a new area in the toolset. I’m talking “added tiles/groups to a NWN:EE base .set” type of customized.

When I say it “does not appear,” I’ll clarify: I mean it shows up as a blank space in the area list. Now, I’ve done what google-fu I could to try to pinpoint the exact problem, but I cannot for the life of me find someone else reporting on this issue, although I cannot possibly be the only one to have experienced this.

My question is not “how do I fix this.” My question is more along the lines of “why does this happen?” I am very much interested in why the stringref of the tileset is not appearing in this list, while its .set is most definitely still present. (Although any attempt to create a new area using this undead tileset just results in the message “Could not create new area.”)

Actually, curiously enough, this happened to me when I tried to load in LoW’s Seasonal Forest v10, Sen’s Seasonal Workshop, and the separated tilesets .haks.

So far I have tried the following:

  • restarting the toolset
  • restarting my machine
  • renaming the toolset in Set Editor
  • renaming all references to the toolset in Set Editor
  • thoughts and prayers
  • devoting the rest of my life to an Old One

Any wisdom you can give in regards to what I’m not understanding would be spectacular! I am not very technically-savvy, so any and all help/contribution is appreciated, especially such that points out how/why I’m being dumb.

Thanks in advance!

Maybe rebuild? оО

1 Like

Hey, @Victorixxx! Thanks for the reply. I am so sorry, but I did not see this until today!

I ended up using the .sets “as intended” as part of their hakpacks. Honestly, it might’ve just been a karmic slap on the wrist for repackaging assets which were not mine! I wanted to make it more…streamlined, is that the word I’m looking for?

In any case, thank you for the reply. :smile:

1 Like