Toolset crashing more frequently access violation

My toolset is crashing after I F9 to test the area and then exit back to the toolset. I try to change something or delete a character I get the error

Access Violation at Address 0083a460 In module ‘nwtoolset’
read of address 00000004

It used to happen every so often now its happening every time after I test the area

all i can say is that i’ve long since stopped running modules from the toolset (what’s happening to you was happening to me until then suddenly half my module disappeared from my hardrive …) <- that’s a warning btw


@kevL_s Gaaak! :grimacing: :astonished:That’s really scary. I quite often test areas and do other small tests running the game from the toolset. Better stop that then, I suppose.

No need to be scared. I always run my modules from the toolset and never had any trouble (other than the auto-save one). But if at least one person, KevL had an issue then it means it could happen… even on rare occasions.



Do you reboot your computer regularly or not? I have found that if you are one of those that do not reboot your computer regularly, then such things do occur.

However, I am like KevL and NEVER test my module this way any more after a bad experience where I lost data too. It was a long time ago, and having it happen just once was enough for me to test modules directly from a new game, or a load game if just changing a few campaign scripts.

Cheers, Lance.

Well, when it comes to this it has never happened to me either, and I run the game from the toolset really often when testing, but it’s good to know that it could happen. However, I backup my module directory folder quite frequently, so even if it happened I think I would be ok.

@Lance_Botelle It was really good to find out about rebooting my Win10 every now and then. I actually experienced “stutter” in my chapter 3 module again very recently when testing, but all was solved by rebooting. So, in my case I only used the Client Extension for a short while, I don’t use it anymore, since I had some small trouble with it, and I don’t think it is needed anymore, when remembering about rebooting every now and then. And on my laptop the Client Extension screwed up my module to it not being playable…

1 Like

I’ve been testing module builds for years from the Toolset. I’ve never seen a problem like that described. I have to wonder if it was an OS glitch.

Hi rjshae,

I don’t think its the toolset directly, but how reliable its working relationship is with the OS. As mentioned in another post, it is more likely to be related to Windows memory management when working with older programs. That is why normally a simple computer reboot is all that is needed. If I was to look deeper, I would consider the possibility of a failing SSD if installed, which with some earlier models I have known to cause similar results with programs. Again, rebooting often sorts the issue. As it appears a memory issue, it just sounds like data going awry, which can be due to a number of parts. I would start at the most obvious. :slight_smile:

Cheers, Lance.

What is F9?
For launch the module i press Ctrl+F5.

Just installed NWN2 on my new Dell (Intel i5, Intel graphics, 12 gB RAM, Win10 Home ed). The game will only run in windowed mode and the tool set won’t run at all.

I’m actually a bit encouraged that Win7 support has stopped so Micro$haft can’t do anything else to destabilize my older HP PC. I can still do everything I need on that at least.

Hi GCoyote,

You need to install directx_aug2009_redist … I’ll try to find the link.

Link removed because of reports of possible AV issues.

Cheers, Lance.

Here is what it should be …


I thought that was included in the GOG download?

Oh? I don’t know … I don’t have that version. If it does, is it included as a separate file that is left to the user to install or not … in its own folder somewhere?

Cheers, Lance.

I don’t remember but I’ll try to figure it out tonight. File saved, thanks Lance.

1 Like

I uploaded an image of the file I have (in post above) that works … Just be sure it matches this info.

File info repeated here too…



Hi KevL,

Are there differences/benefits to the June 2010 version over the other then? i.e. Is it worth my updating … should I update … does it work alongside?

Cheers, Lance.

I’m not sure, i’ll leave the link up although the title on that page (returned on a first hit from Google for “microsoft directx 9.0c redistributable”) says “DirectX End-User Runtimes (June 2010)”

whereas the 2nd hit that google returns is for the webinstaller, and that page is titled “DirectX 9.0c End-User Runtime”

but I see that i have the first download “directx_Jun2010_redist.exe” in my Drivers/Directx folder so that’s very probably what i have installed.

The long and short of it is, if your system works as is then I suggest don’t muck w/ it …

LOL … :smiley: Yeh … That’s what I guess too. By the way, I also noticed that the link I made had a drop down to some other versions too. But, I’m always a little nervous to change a version of DX stuff, once I have what I need working.

That said, I believe you can have more than one version installed at a time, but perhaps it’s better not to mess if working, as you say.

Cheers, Lance.

my limited understanding is that Dx9.0c is a sort of cutoff point for some older games like Nwn2. After that they (microsoft) went to Dx 10, 11, 12 …

So newer Windows computers get the most recent version of Dx (i suppose) and when we Nwn2 users need 9.0c, its setup doesn’t say, “You have a newer version of DirectX installed. Cancelling setup.” (or whatver)

in other words, 9.0c sort of co-exists with newer versions of DirectX.