Toolset (EE) hangs

Yesterday the Toolset stopped working. When I try and load any area in any mod, the Toolset just freezes with a not responding status.

Pretty weird because the day before it was working fine. I have tried uninstalling all mods and then validating using the Beamdog client, but still get the same problem. The NWN Toolset works fine loading the same Mods (installed on NWN).

Running Windows 10 and EE 78.8187.

Any thoughts on what I could do to resolve this will be very much appreciated.

Have you tried bypassing the BeamDog client and launching the EE toolset directly from its folder? At least that way we can find out if its a client issue or a toolset issue. It will also allow you to check the filesize of the toolset on your machine. On mine it comes in at 8,001 KB.

TR

Thanks for responding.

Mine is 7.81 MB (8,195,072 bytes) - so looks to be the same size.

I actually use NIT to launch the Toolset, which specifies the location of the User Folder on the Toolset call line.

I tried launching it directly and at first it loaded, then after a short time it crashed. Second time it hung for a while then crashed.

Really strange that it was working and then suddenly stopped.

Any other thoughts?

Try to delete the ‘nwtoolset.ini’ file ! That works for me each time Aurora crashes…
But I don’t know why the toolset crashes… :confused:

If @kaliopsys’s suggestion works I have one of my own. Immediately upon the toolset working create an archive with the working nwtoolset.ini file in it. That way you can compare a working version with a “broken” one in case you want to submit an error report to BD.

TR

1 Like

Thanks for the suggestion. Unfortunately, it still doesn’t work :frowning:

Similar to this?

Looks similar, except that the mod always loads, the hang happens when I try and load any area.

I didn’t see any solution to the problem in the thread (only saying this in case I missed something).

Looks like a driver-based variant of a previous error I’d reported.

“Yesterday I had a problem with toolset crash on area load when I updated the NVidia driver to the latest version 419.67 realised 03/25/2019. This issue solved after downgrade to older driver’s version…”

Many thanks for this - looks like the driver is the culprit - I have the same version.

I have reported the issue to NVidia.

Latest NVidia driver does not resolve Toolset hang problem :slight_smile:

Given that the NWN Toolset does not have the same issue, I wonder if there is something Beamdog is doing that should be changed to resolve the issue.

I live in hope that one side or the other resolves this problem.

Last I heard, rolling back was the answer. I’m still on an old driver, no problems so far.

Thanks for that. I am aware, but would like to see the issue resolved when using the latest driver, hence my post.

1 Like

I am pleased to say that the latest NVidia driver (v430.39) resolves the hang issue.

3 Likes

The latest NVidia driver (430.86) causes the EE Toolset to hang as before. I have sent feedback to NVidia. Really frustrating.

I can’t decide whether the EE Toolset is doing something borderline or whether NVidia is just messing things up for perfectly legitimate graphics card usage.

( and this is why after 25 yr of computer use i no longer jump up and down “oh goodie!” when a software update is released )

now it’s more like, Twist my arm and bite the bullet,

Open the nvidia control program. Under “2D Settings” choose “Manage 3D settings”. In the dialogue that pops up select the “Program Settings” tab. Wait for the drop-down box to finish populating. Use it to select nwtoolset.exe. In the large box under “2. Specify the settings for this program:”, scroll down until you find “Threaded optimization” (it’s close to the end of the settings). To the immediate right of that you will see it is currently set to Auto. Click on that and select off. Click on the apply button. The toolset should now work properly.

TR

1 Like

Many thanks for this - fixes the problem.

How did you find the solution?

Beamdog forums for a couple of driver updates before. I confirmed that this update messed things up again and so tried the old solution which thankfully worked.

My guess is that the toolset, due to both its age and its requirements, is only single threaded so something about trying to multi-thread the graphics screws things up.

TR

Thanks for the info. The answer reminds me of my mainframe assembler programming days, where I diagnosed an issue that was pretty much the same thing. Just goes to show - some things never change :slight_smile: