[toolset] Issues in campaign settings

So, I’m working on a little project, this project must have the following characteristics:
-Unrestricted level up for companions,
-the companion selector accessible from the menu at the bottom left not visible,
-the additemproperty() command working, (you may be wondering what the last thing has to do with it)

Well, if I set the default campaign of this project to NX2, i.e. storm of zehir, the additemproperty() command doesn’t work. It is totally ignored. The rest of the script works fine, but the properties are not added to the objects.

How the heck is that possible?

If, without touching anything, I assign to this project the default campaign NX1, ie MotB, the scripts work correctly and the additemproperty() command as well, but I lose the Urestricted Level Up option.

If, still without touching anything, I create a custom campaign for the project, everything else works but I can’t set it to not show the party selector option from the bottom left menu.

Campaign NX2: additemproperty() command does not work.
Campaign NX1: I lose the unrestricted level up option for companions.
Custom campaign: I can’t remove the party selector from the bottom left menu.

Some idea?
Does anyone know what happens to the AddItemproperty() command with the NX2 campaign?
Does anyone know if there is a way to enable unrestricted level up for companions via script?
Does anyone know why in a custom campaign I can’t remove the party selector from the bottom left menu?

I hope someone can tell me something, because it’s really frustrating wasting time on these things.

1 Like

If it’s the Party Roster screen you’re talking about you may want to take a look in this thread where we discuss it. It all depends on which version of the xml file you happen to have in your game at the moment:

1 Like

I’m sorry but it doesn’t help me.
My ideal solutions would be to make the AddItemProperty() command work with campaign NX2 or to be able to enable unrestricted level up for companions with campaign NX1, via script.
Using a custom campaign is the least of my favorite options.

Custom campaign? Don’t know what you mean. If you put the correct playermenu_popup.xml in your override folder everything is solved.

If I put the playermenu_popup.xml file in my override, will this affect all my other modules and projects?
That doesn’t seem like the right solution at all.

By custom campaign, I mean a new campaign created in the campaign editor.

If you create your own campaign, you should be able to put any special assets the mod requires in the Campaign folder. When you do that, you normally won’t need an override once the campaign is set up and working.

1 Like

So, I fixed it and made some discoveries in the process.

If I set the module on the storm of zehir campaign, any item sold to a merchant is reverted to its basic blueprint form, forfeiting any modifications made to the item in game.
The additemproperty() command works, but it doesn’t work if you want to modify an object inside a store’s inventory, because as mentioned before, any modification made to the object is lost when it enters a store’s inventory.
I could not avoid this thing, and I gave up.

Meanwhile I luckily discovered that there is a command to unlock unrestricted level up for companions via script.

Finally I set up my project with the mask of betrayer campaign, and scripted the unrestricted level up for the companions.

1 Like

A modified item may revert if it was not given a unique resref before it was added to the store. I’ve seen that happen in other modules.

1 Like

i think there’s a call when opening a store that recreates all items from blueprints

not sure about details atm

[edit] in ginc_item

void RecreateItemsFromBlueprint(object oObject=OBJECT_SELF);
1 Like