I prefer to use underscore_function_names
in executable scripts for convenience and XYZ_CamelCaseFunctionNames
in library scripts for blending with baseline nwscript. It seems to strike a good balance.
Just why they didn’t put such helpers in the standard library (or maybe they did?)…
float Float(int iInt=0, string sString="")
{
return (iInt != 0) ? IntToFloat(iInt) : StringToFloat(sString);
}