Unable to cast spells given to sorcerer via toolset / character editor

I just recently replaced my computer and installed the GOG version of NWN2 Complete again.
I had a single player campaign I never finished and was going to start playing again. My main character is a sorcerer which I previously had given all spells to, somehow.
On my new computer I have all my save files, exported characters etc but I’m simply unable to get my sorcerer to the correct “state”.
I have tried enabling “HasAllSpells” or whatever it is called in the toolset which enabled all spells for my sorceror again, but when trying to cast anything other than the spells which showed up in my spellbook before doing so I constantly get “No uses or preparations left for that spell” for any spell which was made available this way.
I have also tried the NWN2 character editor and I’m having the same issue there in single player, multi player new games, any previously loaded saved game etc.
I don’t know how to fix this, as this was working just fine a month ago on my other computer.

It seems as if the spells I manually added are somehow in a state of “not usable”.

Is anyone aware of a fix for this issue? I don’t really want to play the game anymore without this.

Is there a sub forum my question would be better suited for or maybe I’m just out of luck? Still hoping someone has experienced the same issue before me and maybe found a solution :slight_smile:

hiya,

i think you’re kinda on your own territory there. Granting ‘all spells’ to a sorcerer is … well, you know :)

personally I’m surprised you got it to work before o.O

 
An easier tweak is to simply allow Sorcerer to swap in/out spells on every levelup, instead of every 2 or 3 levels (or whatever it is) ← that’s what my setup has, but id have to look it up …

Thanks for your reply. You are right, that might work.
I still don’t understand why granting all spells to a sorcerer wouldn’t work. I mean the option is available in the Toolset and made all spells available to my sorcerer, just when trying to cast them I get an error message. I know this worked before, and it doesn’t make any sense to me to even include a “give all spells” option just to then have some sort of soft lock preventing the user from casting the spells.

Unfortunately I don’t want to / can’t recreate my character, otherwise I’d just do what I did before which is edit the amount of spells given a sorcerer per level, select the spells during level up and go from there. Even that was tricky as when you add too many spells per level and you end up having more spells selectable than are available you cannot complete the level up as it forces you to pick a spell.

Either way, I’m still looking to accomplish granting my sorcerer all spells and continuing my save game.
As mentioned before, my character currently has all spells available (using a character editor) but I still can’t cast them.
I was hoping someone would know what prevents characters from casting spells even though they have them available.

The spell level is not the level at which the character can cast it, but the number of points in the class ability above 10 that it requires. For example, an 18th level sorcerer with 15 in Charisma will cast spells up to level 5, but a 17th level sorcerer with 19 in Charisma can cast 9th level spells.

Thanks, but that is not the issue I’m having.
My sorcerer is level 20, has something like 33 charisma and can cast level 9 spells.

I added ALL wizard/sorcerer spells to his repertoire, once by adding them manual with a character editor, another time other time by modifying the classes file with the toolset and enabling “HasAllSpells” or something similar.

In-game, my character has every wizard/sorcerer spell available. But when I try to cast it right before the spell goes off (after the targeting when using an AoE for example) I get the message “No uses or preparations left for that spell”.

This doesn’t make any sense because it shows exactly how many more times I can cast those spells for every spell level, and it does not require components or anything else to cast. Even when I sleep I get the same message.
I can, for example, cast 13 level 1 spells. And of the entire list of wizard/sorcerer spells only 4 or 5 work, all the other ones I manually added are not properly recognized by the game.

I would understand this to be a moot issue if it never worked before, but I had a perfectly working savegame with this character working exactly the way I need it to before I upgraded my PC.

Now that I’m on a new PC but still using the same version NWN2 Complete from GOG.com, and even using the very same save game from my previous computer the game just won’t let me cast those spells, even though it even remembered the hotkeys I had setup for my spells on that character.

I need to find out what triggers the “No uses or preparations left for that spell” because it worked just fine 3 months ago on a different computer and I cannot get it to work anymore on the new computer.

Besides, if the “HasAllSpells” option is available in the classes file and can be switched on and off with the toolset it doesn’t make any sense to me for the option to not work in game. Why include it in the first place then?

There has to be someone who can help with this issue? I mean the tools to do what I meant to achieve have been given by the toolset, so why is it not working?

I use the NWN2 Character editor found here NWN2 Character Editor | The Neverwinter Vault. I just created and leveled up a sorcerer to 11 level. I then saved the game, used the editor to edit the save game and give him 4 extra 5th level spells, saved the character, reloaded the save game, rested, then was able to cast the new spells I added to his spellbook. So you might give it a try. Now my game is not the GOG version complete version, I loaded it from disk and updated all the patches years ago. I hope this helps you out.

1 Like

Thanks for your reply! What you described is actually exactly what I did previously to create my character. My only problem now is I’m pretty far into my first playthrough of the campaign and would like to fix my main character instead of having to start over. Using your/our technique though I don’t think that is possible as I would have to create a new character and lose my story progress.

I don’t understand why something so simple, which has previously worked and should even be possible without any issues using the toolset seems to be so difficult to do.
Are we the only ones who enjoy playing a sorcerer without their spell limititation?

I’m sorry that doesn’t work for you, I know in the past I’ve had to change spells for my PC mage when I accidently picked the wrong spell and it always worked. That about all the help that can offer.

1 Like