Unarmed Animations Switch

Hello guys,

I was wondering if there was an solution in how to edit unarmed animations? I’m only looking for my (male) character to retain default unarmed animations, the ones which you have before getting Improved Unarmed Strike feat (which you get for free as Monk). I’m a newbie when it comes to editing/moding so if someone has an easy solution I’d be grateful.

Thanks!

1 Like

The easiest way would be to copy the p_hhm_una_1attack01.gr2 (attack02, 03 and 04 as well) from the lod_merged*.zip files in the NWN2 \Data folder into your \Override folder (the one in your \My documents directory), and rename them by appending a ‘b’ and a ‘c’ to the name (so you’ll get the p_hhm_una_1attack01b and p_hhm_una_1attack01c.gr2 files the game uses for the improved unarmed animations).
Note that doing so will change the animations for every monk in any module!

2 Likes

First all, thanks for the tutorial. I did what you said and it worked, but only for off-line modules. Is there a way to make it work on a Persisent World server?

No, since most PW servers automatically disable content of the client’s override folder (for obvious reasons). So the only option here is to contact PW admins and ask about adding this change to PW server.

I had tried as your steps, but it did not work, I don’t know why. i copy twice the “p_hhm_una_1attack01.gr2” from “lod_merged.zip” in NWN2 Complete\Data, to the \Documents\Neverwinter Nights 2\override, so i have two p_hhm_una_1attack01.gr2 files in override folder, then i appending a ‘b’ and a ‘c’ to the name(now i have the p_hhm_una_1attack01b and p_hhm_una_1attack01c.gr2 files)

after finish this, my monk unarmed attack still don’t have “impact animation”

Look forward to your reply

Well, it could come from several things:

  • you’re playing a monk who is not human (that’s the ‘hh’ in the “p_hhm” prefix)
    or
  • you’re playing a monk who is not male (that’s the ‘m’ in the “p_hhm” prefix)
    or
  • the “impact animation” is not “una_1attack01b” nor “una_1attack01c”.

If you do play a human male monk, I’d try to change the “01” in the the name of the files in your override to 02, or 03, or 04. If it still doesn’t work, try with 2attack01b and 2attack01c

If that’s still not what you want, please clarify “impact animation”.

Thank you for your reply.
my character is a male human monk.

the “impact animation” i mean is: the sound and visual effect when my character hit the enemy, just the following two screenshots show

Pic.1 my monk hit the enemy, not SFX & VFX, just like hit the air

Pic.2 my companion(fighter) hit the enemy with unarmed, it have SFX & VFX

by the way, i have change the 01 to 02, and 03, and 04. it did’t take effect

and this BUG also discribed by this guy
https://gamefaqs.gamespot.com/boards/922154-neverwinter-nights-2/57185625