Underlines In Conversation (Toolset)

Does anyone know how and why the underlines appear in this OC conversation … ?

It may be useful to help highlight certain aspects of a conversation during build time if it is simple thing to do … (I know how to add comments.)



think of it as a link from an NPC-node to a previous NPC-node, but instead of the NPC reshowing its previous node, only the PC responses are then re-shown to the player (except for the response that the player is currently under).



Wow! After all this time, I had no idea it could do that!

I believe I could have done things a lot differently even in some conversations now … At least I can start making use of that if I have understood correctly. I am going to play around with what you described and see how it works out.

This sounds like it will answer a lot of my setting of local ints in conversations!

Thanks for answering. :+1:

EDIT: It is quite confusing for me to get my head around at the moment (in trying to use it), but I think I can see how it works now - I will keep playing around with it and see if I can get results with which I can use.

EDIT: OK - I got something about the logic now (very useful when used with Once Per Module nodes) … Thanks again!



hey Lance, I don’t/won’t use those myself. 'Cause i don’t know of any way to clear them for, say, debugging a dialog if you want to run the node twice … or if something happens to go wrong during a playthrough and a player needs to rerun a conversation.

the (tried and true) method of setting and checking local_ints, on the other hand, are easy to clear


I totally agree with you about not using the official “Once Per Node” tick box, as it has caused me some no ends of trouble in some situations where the conversations get really heavy. So generally, like you, I stick with tried and tested local ints.

However, I am slightly tempted to consider using them in this situation if the info is not critical and I am certain these are nodes I am not needing to revisit. Or is that being tempted to the “dark side”? :wink:

Completely off topic … I decided to “fix” a spell I had “broken” (Charm spells) when I tried to allow a quick and easy way of allowing players to charm vendors for discounts. I was pleased to discover (after repairing my own target mess up), that breaking the spell into two for allowing a hostile and friendly target does work. By default, the spell can be kept “hostile” target for quickness of usage, but I have just successfully tested the ability to target a friendly by a second category usage of it. Fix coming in next release. (Edit: Strictly speaking, and with some work, you could arguably do this with any spell. Remember when we were trying to target magic missile on a friendly? Personally, I am sticking with changing a target hostile with a button and then targeting such an obvious hostile spell - the spells still need editing, but I found it an interesting alternative approach for some spells, like the charms. Although, I am only allowing it on Charm Person and the Charm Animal/Person one. Not the Charm Monster now.)


re. targeting hostile and non-hostile: can be done w/ 3 entries in Spells.2da … a Master spell w/ 2 subs

HostileSetting set 1/0 (on the subspells) and spellscript(s) coded appropriately.

Yep! That’s exactly what I did. :slight_smile:

While in “off topic” mode … Do you have any reason why one targeted creature will show a saving throw response (save or fail) after being targetted with a spell and another creature not show any feedback at all with the same spell?

I am testing the altered spell (as discussed) and one creature always shows their saving throw response, while another does not … At the moment, I am checking if the appearance type is having any bearing.

with the same subspell? (ie. hostile)

I notice that only the character that cast the spell gets to see the save. That is I have to be controlling the character that cast a hostile spell, when the spell hits, to see a target’s save message.

That’s what I thought it may be originally, but I am now only controlling the Main PC and doing the casting on two different NPCs - one shows the feedback, but the other one does not, save or fail. Debug feedback confirms the script is firing.

The appearance makes no difference, I am now trying the class.
EDIT: No, classes make no difference either.
EDIT: Creature size no impact.

This is weird.


DOH! … One creature was set at PLOT! That stops the feedback checks! To be honest, I did not realise that would have stopped it, but when I noticed the diff, this stood out to me straight away.


ah, thanks for the reminder

1 Like