Unusual "Area Loading" Problem

I have an area (16 x 16 external) that I have no problem with … on my computer.

However, on my wife’s computer, when she enters it for the first time (and first time only), it can either crash on entry or crash after entering. Then, after reloading, it’s never a problem again.

I first tried preventing the area scripts from firing, but that made no difference. Therefore, my guess is that there is something strange about the area itself. I tried re-baking it, but again, no difference.

So, does anyone have any ideas what may the issue?
Have you ever experienced something similar?

Thanks in advance.

A couple of ideas…

Are your wife’s computer’s graphics settings different like far plane, water refraction or something like that ? If so set them up the same and see what happens.

Is there something in an unbaked area that shouldn’t be there like an npc that jumps into a baked area causing the crash ?


Well, the settings on her computer are “lower” in general. However, the area loads OK with the same settings on a reload. Just not the first time entering.

Nothing in any unbaked area … neither any WPs to assume any kind of jump there either. And again, the area loads OK on my own computer the first time as if there were no problems.

It’s weird … I wondered if something else occurs on a first load.

Black skydome ? It make the game crash.

2da mess can also do that.

Wonky walkmesh as well.

1 Like


No Black skydome used … check!
2da all appear in order … check!

Walkmesh … I did try a rebake, and that made no difference. I also tried deleting the trx and trn files to allow a full rebake, but that lost the entire terrain/water etc, so I could not test it that way.

Although, maybe there is still something not quite right even though it appears good elsewhere.

A bad loop that doesn t end correctly. I also crashed beceause of that.
Also a mess with custom GUI.

A faulty hardware component :stuck_out_tongue: But that was at NWN2 beginning.

1 Like


I don’t think it’s any of the scripting or GUIs as they do not even get used at this point in the area loading - and again it all appears good after the first load for her anyway - and is never a problem for me at any time - and why just this area?

Faulty hardware - now that is always possible I guess … although, the issue appears reasonably consistent and repeatable. Even if I change the module folder over for a copy from my own computer.

And while it can simply be overcome by reloading … it’s something I would rather avoid, in case it is something that happens on anyone else’s game.

Take out things one by one until the crashes stop. Only thing i can advise, and that’s how I proceed when I am in those situations.

1 Like


Yes, I think it may come down to this … a right pain to do, but maybe unavoidable in this instance. I guess I could work on groups of objects (such as VFX, sound, etc), because one by one may take too long. :grinning:

I just do not understand this particular issue as it appears consistent, but without any apparent real reason.

1 Like

FWIW, are you both on exactly the same OS? Is the graphics driver on wife’s computer up to date? Have you got anything NwN 2 installed that she doesn’t and vice versa.



Both on Windows 10 - both fully up to date.

Both have fully up to date VGA drivers - Both using NVidia cards.

Both have the same NWN2 installations - from own original discs.

All have latest haks, campaign, tlk and module files and folders.

Interestingly, my wife just had a complete freeze in the same area for the first time too. And that’s after she does not normally have the issue. Although another quick reload and all is well again. :thinking:


And, just to be complete, do you use NWN2 Client Extension while your wife launches the original NWN2.exe?


No, neither setup uses that. I found it caused me to have slight stuttering when I tried it once.

I suppose you already checked the override folder, but what about the localvault (where all the player’s characters are saved)? I know that characters created while some haks allowed additional customization do crash the game when said haks are no longer available (typically because the module/campaign is uninstalled).
But then it crashed the game every time in my case, and not only the first time.


Override is empty.

No additional customisation on any of these PCs. We also tried with different PCs just to be sure.

I am trying to muster the will to do the bit by bit removal of area objects now … If I discover anything, I will let you all know … unless somebody comes up with the solution first. :innocent:

Hi All,

Latest … After removing some VFX, I thought I may have “fixed” it … BUT (and this gets weirder now), I had also toggled my TEST variable on so I could get some feedback. And I discovered that with this TEST variable set the area loaded fine, even after I reinstated the original area files.

However, at first going through the files, I cannot see how or where this variable makes any difference. (There are a lot to follow.) Most just enable text feedback of variables. I thought I found something when the variable also stopped something to do with Unacquiring an object, but further testing proved this a dead end.

So, currently, I am veering towards some small bit of code that may be having an impact on my wife’s game, but to be honest, I currently cannot see how or where. I will try and trace every path this test variable takes to try and see if and where the difference may be.

However, with it set to TRUE, it has never failed. This appears more than coincidence to me, even if there is currently no logical reason I can find behind it. I’ll look some more and try to keep you updated.

UPDATE: OK, I have gone through EVERY instance where the TEST mode is enabled and there are only two places where it could possibly have an impact. The first instance, I had tested out when I tested the area with the entry scripts disabled. And the second instance, when a PC unacquires an item never showed any debug feedback as having fired. Although, I am a little suspect of this and so even added some check for valid items too. However, it still crashes after a few tests.

So, I am now none the wiser. Why the area should “work” when there is effectively more work going on at times (debug feedback enabled) as opposed to not, I don’t know. I’ll keep an eye open moving forward, but for now, I think that will have to do.

Stick in an auto save before the area just in case it crashes other people’s computers to be safe, that way they wont get angry.

I had considered this, and it may be the last resort. :slight_smile: It’s more of a frustration that it’s not something obvious to find that frustrates me more than anything else now.

I may wait to see if I can get further feedback from any players who may try playing it.

I know it’s not the same but I did it with an area that sometimes crashes if the PC’s a caster because it’s got loads of water, arrows flying everywhere and with two casters in the party a third one freaked my computer on more than one occasion.

1 Like

In my latest modules I’ve worked on, like part 3 and 4 in my series, I’ve always had one or two areas that did the CTD. However, you could always reload and then the problem would go away (it could return though, but then you just had to reload again). These areas were almost always big though, with lots of stuff and characters, and according to @4760, my trusty beta tester, the problems would always go away if you had Client Extention installed. The only reason why I don’t use the Client Extension, is that on my laptop (not my main computer, that is) one of my modules wouldn’t work with the Client Extension. I always mention though in my releases, that people can always use that if they want to be sure of smooth sailing, if they have had no issues with using the Client Extension before that is.

Many times the crashes had to to with big battles being fought with spell casters and whatnot, just like what Tsongo describes.