*Very* slow area unload on my client

There is one area in the module that has an extremely slow wait to leave the area. The “Unloading area” progress bar is at zero for literally almost 30 seconds before it starts to move. If I am running single-player and quit the module while in that area, there is the same long delay to get back to the main NWN menu. No other area I has this issue, that I have seen.

This is seeming client-side to me. When I run the module as a server and leave the area, the server doesn’t seem to have any trouble (low CPU usage), but the client is stuck for a long time and Windows is showing around 12% CPU use for the client, which is pretty high. And, I have enabled profiling for the server and there is nothing unusual in terms of scripts hogging the CPU.

It’s also likely that this is client-specific. I tried the same tests (leaving the area to go to an another area and also just exiting the module from the area) on my older PC and the problem is negligible. On the older machine, the unloading/exit might be slightly slower than from another area, but any difference is barely noticeable. The newer machine is mostly faster (newer CPU, 64 GB RAM instead of 16, newer SSD, etc.) But, it’s graphics are not as good. The old machine is running a nvicia GeForce NTX 970, whereas the newer machine (a laptop) has an Nvidia GeForce MX550.

This is more of a guess than I would like, but it is possible that some resource (object model, terrain, etc.) in that area is causing this? I’d like to track it down, but this is outside my experience.

You wouldn’t be on 35 patch by any chance? I’m getting the same thing with my starter area which is 7x10 and has less than 70 placeables and no creatures other than the PC. In my case, I’m thinking it’s the rain and lightning effects being enabled.

Disable the experimental shaders. These make my machine tank in many areas - even some vanilla ones - on my machine.

Might not be it for you but it definitely was for me.

I am on v87.8193.35-40. Is that the patch in question? Interesting that it would stall when unloading an area like that. Is this a reported issue?

Thanks for the suggestion. I disabled those, but I am still getting the same huge delay when exiting that map.

The area uses Worm’s Cypress Swamps. I wonder if they are connected to this somehow.

If the problem isn’t reproducible on other machines, then it’s most probably more or less a hardware or OS issue. This might be well caused by a certain object or tile. I once tracked down a massive loading time issue in a area, it turns out that the encounters were the reason.

You could make a copy of the area and check if the problem is still there. If it is, then delete all stuff to check if it’s a placeable/creature etc. OR the tileset.

Yeah, 35-40. I personally haven’t reported it to the Dev team as it doesn’t do it in the preview patch. Unfortunately, I’m planning a Halloween release for the module and am stuck using 35-40 as the 36 patch probably won’t be ready by then.

Try running around and pointedly into things as much as you can, another thing that in my experience can cause this kind of system-dependent slowdown is malformed collision meshes: old cards will clamp high values whereas newer ones try to compute infinity.

Does it tell us anything that the lag occurs when leaving the area (even when exiting the module)? Is there something the client does when exiting a map? I imagine it frees up some resources and maybe does some garbage collection. Do certain tilesets have issues where they continually allocate more resources such that there will be a massive load to release on exit?

The area in question isn’t the normal worms_cypresss swamp, it’s the fancy-mapped version for EE. I suspect there is no issue with the old 1.69 version.

I walked around that area for a while, trying to run into trees, unwalkable terrain, etc. Then I exited. About 60 seconds lag before the progress bar moved. But, that’s the same as when I did the same test by just entering the area and exiting without walking around.

Good to know.

Well the thought is to find assets with broken meshes, but if you didn’t find anything untoward I think we can rule that out.

How’s your CPU/GPU/Disk use when loading? It sounds like something is bottlenecking.