Voice over questions... c

don’t know what you’re trying to do here. do you stick .wavs to random npcs and look ingame, if the lips are moving? i never really worked with .fxe files but i guess that they have to fit at least the gender of the creature trying to speak the line. dunno if male/female skeletons are different in facial bones, but an .fxe file for a male should work for every male ingame. at least if the head’s model glued to the npc’s body is weighted to the facial bones. this means that there can be issues with custom head packs when the creator didn’t weight facial bones.

Yes I did stick random wavs to npcs in a test mod to see what happened and they all spoke the lines of the wavs with moving lips to match.

I was thinking about doing all the barkstrings in one of my campaigns but wanted to see exactly what was involved. Maybe I can get away with swapping fx files to all the characters so they know how to move their lips…

I don’t know what to do yet, I don’t really want toget bogged down in over comllicated stuff.

Ps.gender seems to be irrelevant they’re very modern these npcs !

Well, when using sound files from, I think it was IWD or BG, and trying to make my NPCs move the lips to those sounds, I had to make fxe files for those. I tried with copying other fxe files and renaming them to the same name as my new sound files, but that didn’t work at all. I had to use the FXE Generator for that to work.

As you say, gender doesn’t seem to matter at all, and if you are just using lines (sounds) that are already in the game, then you already have the fxe files so then there should be no problems.

Pps. How do you set a placeable on top of another ? I’ve forgotten and I know there’s a quick way without fiddling about with the mouse wheel.

andgalf, I was going to make custom voice overs so might need the fx thing after all… That’s if I bother, it all sounds a bit complicated.

Using the FXE Editor is very simple. The thing that may prevent you from using it at all is that it seems to not be working on Windows 10 or Windows7. At least I haven’t got it to work there. For my second module, where I created fxe files, I had to use a really old computer with Windows XP from work, that was going to be trashed, to get my fxe files.

Edit: I wish there was some good programmer here on the vault that could make a 64 bit version of the FXE Editor, or something that would work on Win10.

I’m on windows 7, I think for now this will have to go on the back burner… I’ll stick to remaking areas, it’s safer !

Thanks for all the help, much appreciated…

1st attempt on Win7 64-bit

note: I don’t have a clue what its code does – am going through the syntax though.

@andgalf PM a testbuild in a day or so …


Ah, great @kevL_s! I hope you succeed in making a new version that works! :smiley:

Edit: I just discovered, when looking at my earlier comments regarding this, that I have tested the FXE Generator on Win7 32 bit, Win 64 bit and Win10, and it didn’t work anywhere except for WinXP. So since it doesn’t work on Win7 32 bit, it might not be a 32 bit thing.

I just downloaded the program from the vault, installed it and it appeared to work (created an fxe file). Unfortunately the generated file crashes NWN2 (I compared with a stock wav file, and the sizes are different: 609 bytes with FXE generator whereas it’s 3.6 kb in the game files).
I even tried with the XP compatibility settings on the Win 7 computer: same results, the generated file is way too small (206 b this time!)
I know I’ve got a virtual XP somewhere, let’s see if I can fire it up…

1 Like

i found one egregious bug so far … it wouldn’t let me compile until changed … not sure if 34 (original author) could compile it and the typo crept in later or whot

am tidying things up till it makes sense; fortunately there’s not too much code

it will likely take more than a day to actually get some IG tests done,

@4760 Was that small file the output of a .FXE or a soundfile ? What button did you click to generate it?

It was the output of a sound file: open, type the text to help the recognition (in “Actual text”), generate, change to P_HHM, make FXE

1 Like

Yes, it works flawlessly, even in a virtual machine, under XP.

1 Like

so the flaw or flaws seem related to the Operating System type ( and/or its appendages like .Net ) …

/crapshoot :confused:

kevl_s and 4760… I have absolutely no idea of what you are doing involves or how you are doing it because digging around in things like that scares me and I’d need to back up my computer before starting, just in case it went horribly wrong…

Good luck and I wish you success !

1 Like

@kevL_s @4760 - This is the error message I get as soon as I click “Generate” in the program. (Sorry that the text is in swedish)

Error message

I have Win10 Pro on this computer, and on my laptop I have Win10 Home, and it doesn’t work on either of them.

When I generated FXE files on the WinXP computer there were no errors in the game. @4760 So when using your virtual XP there were no errors correct?

1 Like

Yep. The generated fxe file worked correctly in game.

Re your error message: are you trying to overwrite an existing fxe file? I can’t read Swedish, but I got an error message while I was trying to create an fex file on my Win 10 laptop, allowing to continue or quit, and it looks like you’re having a similar message there. As soon as I removed the previous fxe file, the error disappeared. Unfortunately, it didn’t mean the program worked.

No, I wasn’t trying to overwrite an existing file. I can press “Continue” as you suspected, but if I do that, nothing happens at all. Then if I try and press Generate again the same thing happens, so no fxe files are created.

If it is possible to make this program run on a virtual Windows XP, shouldn’t it be possible to make it work on Win10 also? I have no knowledge of such things though so…I’ll leave it into kevL_s’ capable hands and hopes he manage to solve the thing.

/what is this madness

generate looks like it worked ( win7 64bit / .net 3.5 )

ps. You guys may or may not be experiencing a Permissions (hard drive write) error … the app writes temp files in its own folder …

will try to change that so it uses the Windows Temp dir instead etc.

1 Like

In your picture everything looks correct.

Hmmm, ok. Weird that I tested it on 3 different computers several months back and all had the same problem. Could it really be a hard drive write error on all of them?

I tried again by running the program again on my main computer, as administrator this time, but that did nothing. Still when pressing Generate I get the error message. Could it be that I don’t have .net 3.5 for some reason?

Edit: Through a little bit of googling I found that my computer has indeed .net 3.5 and 4.8 installed. I guess it is part of Win10 Professional.