Walk Through A Door! (rws_codi_sigil) - RESOLVED!

I am using a door from the rws_codi_sigil hak and discovered that the door does not appear to have any “blocking” property. i.e. Creatures appear to be able to walk through it.

TAG: plc_dr_codi_01
APP: Hub_double_1
2DA REF: 590 Hub_Double_Door_1 2 plc_dr_sigil01 plc_dr_sigil01_?? **** plc_dr_sigil01 **** **** **** Hub_double_1 1 1 2 **** 2

I do have the plc_dr_sigil01 files, but maybe there is an issue with one of them?

Anyone else seen this or have a fix?

Thanks!

image

1 Like

If all else fails could you use a normal double door and just change it’s appearance in the properties ?

I tried this, but it seems the “block property” is governed by the “appearance” setting. Or did so in my tests anyway.

I don’t know if this is possible with a script but could you stick a collision box on the other side and destroy it when the player opens it ? It’s nowhere near ideal and a bit messy but it could do the job and nobody will notice.

I don’t see anything strange in the 2da, nor in the model (at least the one I have with the same name). Is the door locked? I know some creatures are smart enough to open the doors :joy:
Are the walls on either side of the door blocking the creatures?

@Tsongo

I had tried this, but the monsters and PCs could still “see” and attack one another through the closed door.

@4760

Tried both locked and unlocked … you could simply walk through both without opening.

The way to test this is to use your keyboard keys to walk through the door. (You cannot use your mouse to get past it.)

One thing you say though is that I will try making the door wider to see if it is not quite closing the gap even though it looks as though it is. I’ll report back …

I can still walk through it even after increasing its size. The door is still useable and blocks player sight into the room until past its threshold. However, all creatures can “see” through it and walk straight through it as if it is not there.

Here is a copy of the door files for both the first and the second door that come with the tileset. The second door is fine, but the first “fails”. I paste the files for comparison of file size against anything you have in case you see anything obvious.

I don’t have any tools to open these files nor to compare to say what may be causing the issue.

image

1 Like

I have found that most of the Codi doors do not seem to have any sort of blocker on them

1 Like

if you really want that model,

-Colision box

-Faction work for the objects to be neutral to each other when it’s closed, and hostile when it’s opened.

Or you need to finish that door object yourself, I have not worked on that field yet, so I do not know how to do it.

1 Like

Everything looks good to me. The only difference is that sigil01 is turned 90° compared to sigil02 orientation. I also noticed that the pivot point is located right between the doors, whereas it’s at the left hinge usually.

So I reset the origin, reoriented the doors and reexported the skeleton and animations. It’s untested though.

2 Likes

I usually see that when a door doesn’t have a C2 collision mesh.

1 Like

@4760

Thanks!

I’ll try this out straight away! Back in a but … Sadly, it still did not work. But, I do thank you for taking a look.

@rjshae Is there one I can copy/use from anywhere else, or is it something that is straightforward to add? Modelling is outside of my skill set, especially without any tools or knowledge how to use them. I think you may be onto something here. Screenshot with c2 showing between doors … the broken door shows no mesh at all.

image

The second door I have with them works OK.

Sadly, I don’t know how either.

Thanks everyone!

I’ll keep an eye open to see if anyone does put something else together for me to try.

1 Like

@Lance_Botelle To fix this the door model needs to be updated and new animations exported, which isn’t that difficult once you know how to do it. Here, give this a try:
https://drive.google.com/file/d/1zBad7XYWf40ebZpe6nSsVAl9IwC4HhO2/view?usp=sharing

3 Likes

@rjshae

Well done! You fixed it! :+1:

Now to change all the doors back again … :grinning:

Thanks for all who helped!

I just realised that I am also going to have to force this fix in my higher priority “patch” hak, as I don’t want to upload the massive hak again (even though that is where I have updated it for my own use.) Ah, I just checked and I cannot easily do that as the patch hak is with the big download anyway. Oh well, I did say v1.50E was a new point in its history, so I will just update the main hak prior release as part of the new download.

3 Likes