Waypoint not working...or something

I’m going nuts. I downloaded a prefab indoor area. In that area there’s a door that is supposed to send the PC to a waypoint. When clicking on the door, the door symbol is there but no teleporting is happening. I can’t for the life of me see what I’ve done wrong here. I’ve checked and rechecked the waypoint that the PC is supposed to be teleported to, I’ve even renamed it, still nothing happens when clicking on the door.
I even checked other areas with doors linked to waypoints to see if I somehow might have missed something. Everything looks as it should. Has anyone experienced something like this? Do you have any ideas? Please help.

I tried linking to another area instead with another waypoint. Same thing. Nothing happens.
As it is now, the door opens and when clicking on it the “door symbol” or “teleport symbol” appears, but when clicking nothing happens.


Can you provide the link to the prefab area you downloaded?

Sure. Eh, I think so. I’m at my laptop at the moment. Don’t have the link here but I’ll try and find it. One moment.

Found it right away. It’s this:


The area in question is the templeneutral.

Thanks for trying to help, travus!

When trying to solve this I even changed the door, and at first I couldn’t paint it in the area (very strange), but when I changed the size of the area I could paint a new door where the old one was. I changed the area to height 8. But that still didn’t solve the issue.

Is that “outs_tem_ro” waypoint in a different module by chance?

No, it’s not. I tried now with just loading the module with the templeneutral and making a random new area and then teleporting there. Now everything worked. So, what I did then, was that I exported the area once more into my module and “copied” all the stuff I had in the area originally to this “new area”. I renamed the waypoint once again, this time to “ootwp” and tested it from the toolset. Now everything worked.
I hope every other thing I’ve put here works now. We’ll see, I guess. This was extremely weird. Don’t know what went wrong the first time I exported this area and then imported it into my module. One thing I remember doing was erasing the “autoclosedoor” script (which I didn’t do this time).

1 Like

OK. I tried everything I have in this small area and everything works now.

One other thing I remember doing before was that I took away a walkmeshcutter around the pedestal in the room and then rebaking the area. Could that have to do with what went wrong before? I haven’t rebaked the area now, since I’ve not changed anything walkmesh related.

I doubt if the rebake did anything to affect the door transition.

If for some reason there was an unwalkable part in front of the door, the party wouldn’t be able to reach it and then the door transition would fail, even if it looks like it’d work. Or so I found out in a few areas…

1 Like

Alright, good to know. As you see in the picture, I think the part in front of the door was walkable, but who knows. I’m glad it works now.