Weird question perhaps - keyboard trouble

Since I have had this problem as long as I’ve worked with the toolset for almost 2 years now, I thought to maybe ask the community if someone else has encountered this.

When I’m in the NWN2 Toolset and trying to write script, it very often won’t recognize when I try to type “=”. When I try to type that, the Toolset oftentimes type “)” instead, but sometimes it types “=”. This has always been extremely annoying, forcing me to use Notepad instead when writing scripts. Now, I have an extremely old IBM keyboard from the early 90’s (which I love!!) that is very nice and distinct. You may then answer: “Well, if it’s an old keyboard of course it’s malfunctioning”. However, it only behaves this way when in the NWN2 Toolset. Whenever I write in Word or Notepad or whatever I never ever have this problem.

Does anyone have any theories why this is?

I got the same problem and haven’t found a permanent solution. Caps lock will give me the ).

edit: what keyboard are you using? Like, format? English or anything else? Because I use a german one and another issue I get is opening the in-game console. I need to type shift + - + ? (don’t even ask how I found out) altogether and it only works half the time.

1 Like

I have a swedish keyboard. It feels good that I’m not the only one having these kind of issues then.

Yeah, the console command is hopeless. I cannot find it half of the times. I think there was some other solution to get to “kind of” the console command (someone posted it here or I read it somewhere, don’t remember) so I don’t use it that often since I don’t quite know how to do it.

I’m also on a Swedish keyboard, and got the same problem when using PowerBar to create or open a scripts, but it works just fine when opening scripts from the standard Script window.

1 Like

Ah…Yes, I have the PowerBar plugin too. How do you create scripts not using the PowerBar then? Do you mean right clicking in the Script window to create a new script perhaps?

Edit: Just tried that, and it seems to work, actually. I don’t like doing it that way, but if that’s what it takes for it to work then ok.

The software developer in me is curious to know why this only happens when creating a script via the power bar…

Would it be possible for you to look into the source code of the PowerBar plugin to see what could be causing this? Or maybe that’s impossible. I don’t know how that stuff works.

my recent experience w/ the CreatureVisualizer plugin have taught me a lot about … stuff.

eg. you don’t actually need the sourcecode of the PowerBar plugin to reverse engineer it in c# – any decent IDE for c# should expose a reasonable facsimile of its code.

that’s not to say it’s easy, or that one could just click “compile” like we do with scripts …

But it’s possible, i believe, and I have wanted to modify aspects of the PowerBar

at the moment all i’m saying is its possible, or something


I’m on a French keyboard, and I cannot open the console either. When I need to run scripts manually, I press “enter” (that opens the chat window) and add ## before the command I want to execute.
##DebugMode 1 will activate Debug Mode then, ##GiveXP nnn will give nnn XP to the currently selected character etc…


@andgalf Did you mention your problem with handling objects in the Toolset you were telling me about the other day? I don’t know if it’s related. Unless you have fixed this annoying problem. :neutral_face:

No, I have not mentioned it, and it’s still there. Perhaps it might be related. Ok, here goes:

When I place a placed effect in an area it’s not “selected” or “marked” or how you say it in english, and I can’t seem to select it properly. So I have to select it in the list of placed effects of the area. When I do that and try to use the arrow keys to move the object, it instead just moves up and down the list of effects for the area instead of moving the specified placed effect.

Sorry, i never had these kind of problem with my keyboard (italian) or the toolset.