Weird visual bug

I have a male half-elf in an area. When I placed him there everything looks fine in the Toolset, however ingame he is both male and female from a certain angle. It’s really odd. I am using a custom head from Jude Inc., custom clothes from Jude Inc. and a custom haircut from Rashi. It might have something to do about that, I guess. All of those files are in the override folder.

Every other character in the area, and all the other areas I have, where I’m using custom armor/clothing and heads all the time, have no such problems. Only here. Any thoughts what could be causing this?

This is how he’s supposed to look like (and he looks like that from this angle):

And here’s how he looks like from a certain angle ingame:

1 Like

The bug seems to have something to do with the area. Don’t know why. I moved the character a bit and I think it works now. Really strange.

Looks like a female character is at the same location… Does the head you use have its own skelnn.gr2 skeleton (where nn is a two digits number)?

This is groundbreaking stuff angalf and it’s good to see NWN2 is moving with the times !

1 Like

@Tsongo LOL!

@4760 When I move around with the PC and the party sometimes weird lines appear, so there’s something really odd going on. I will look into it more. Maybe I’ll post some more pictures here.

By the way, this is an area from my first module that I’m reusing for my fourth module. Maybe I have stuff in the override that are messing with things…I have no clue.

I solved it. I should have known it was something like this, since this has happened to me before.
Sometimes when I have placed a character with a corrupt armor or face or whatnot (an armor I have perhaps converted to be able to use it on both elves and humans, and I have done a poor job with that) the creature might disappear in a way that you can’t see it in the toolset. This can really mess up a whole area and a whole module if you’re not careful.

The way I solved it was to go to the area and scroll through all the creatures that I’ve placed there. Then all of a sudden I saw an empty green box. The box indicated that a creature was there but you can’t see it since it’s corrupt. Deleting that creature made everything work again. No weird glitches at all now.

So, in a way you were correct, @4760. There was indeed a creature nearby, just not exactly at that spot, but I think it was enough to seriously mess with things.