Where Does The File Go? (RESOLVED!)

I have done this before, but now I am not sure …

I need to fix an official script, and I have copies of the MotB campaign and mod files in my documents.

I open these copies and edit a campaign script and save it … BUT, when I go to look for it in the My Documents campaign versions of the scripts, they have not been altered! Yet, when I load the mod again and look, it is still altered.

So where has this file gone to?

It might be in your C ( wherever your game is ) toolset folder if not save/ compile another script and see what it says at the bottom of the screen.

No, I have checked - It is doing some really funky stuff!

Try it and see what I mean …

  1. Copy the campaign and mod files to your NWN2 My Documents folders, as if they were your own campaign and mod.

  2. Open one of the mods and edit a campaign file. (Which should be those copied in your documents.)

  3. Check the file - No change. (Not even a date change as if nothing touched.)

  4. Reload the mod and check the campaign file and it is changed! (But where is the file?) :open_mouth:

It gets even weirder …

Take a copy of a campaign script (.ncs and .nss version) from the copied campaign files and place it in the override folder.

This “version” then shows as a module script …

Close the toolset and edit the NSS version with a word like “TEST” in it and reload the toolset and this mod version. It shows “TEST” … BUT, now edit it further in the toolset. … save and close … check the nss version outside of the toolset and no toolset edits show. :open_mouth: BUT, go back into the toolset and open the mod version again and your old edits are still there! Furthermore, close this mod version and open the campaign version and the toolset edits are there too.

BUT, try to locate this toolset edited version outside of the toolset and it simply cannot be located … by me at least. :exploding_head:

That’s a bit worrying, we could be uploading modules that don’t have all the right things with them if they’re hiding somewhere on our computers !

I’ll have a look for badly behaved hiding things tomorrow because it’s bed time here and I’ve just been having a serious play test of my mod and I’ve had enough now.


I would be interested to hear your results …

However, it is probably not a major issue, as this is only when dealing with OC scripts. i.e. Changing scripts for our own modules works exactly as expected. I just do not recall (or did not realise) that OC scripts could not simply be edited and then the edited version copied from the “copied” campaign folder we were working with.

I am trying a different approach to get around the problem now, by writing the same name script in my own campaign (from an override copy), which I will leave in place when playing the OC. I am hoping the same edited file (which actually means nothing to my own campaign) will still work with the OC!

This appeared to work … Note the HELLO! on a heartbeat call …

hey Lance,

what i did is leave the official /Campaign folders in place under the installation folder and edit those (after making backups). Only the official Module .mod files got unpacked to the documents folder. Then ofc make any necessary changes to the .Cam file(s) …

I also never edit scripts in the toolset. So I know what script is being edited …

the issue you see could have something to do with the differences between the game and the toolset : eg. the game will use Dialog.Tlk in the documents folder while the toolset prefers the one in the installation folder.

Ps. Everything is my friend :)

1 Like


Where are the campaign script files located that you edit outside of the toolset? Do you edit the install campaign files directly then (from those inside the install directory)?

Well here is my situation …

I have the normal installed official campaign and module folders and files in the C:\Program Files (x86)\Atari\Neverwinter Nights 2 directory. I leave those alone.

But, I also copied these campaign folders and module files to their appropriate C:\Users\lance\Documents\Neverwinter Nights 2 folders so I could take a look at them in the toolset.

I opened the copied A_X1.mod using the toolset and opened the k_mod_hb campaign script … as this is where I was going to apply the fix (for simplicity).

Edited it and saved it using the “Save and Compile” option (NOT the module), in the same way I do my own campaign scripts, expecting the campaign script in the copied campaign folder to update.

I closed the toolset, went and checked the nss version of the copied campaign file and NOTHING had changed. Not even the date of the file. (So, like Tsongo thought, I wondered if I had somehow changed the main toolset campaign script instead, but when I checked that, it was also untouched.)

So, I thought perhaps I had not saved it correctly and reloaded the copied A_X1.mod, and the file HAD been updated with my code. :open_mouth: But, I cannot find where the updated k_mod_hb file is anywhere in any NWN files.

Here is the files I expected to be changed, but it had not…

EDIT: Removed some erroneous info to avoid confusion … But, basically, even if I removed the copied campaign folder, the results are the same. The loaded copied module, somehow still has campaign files associated (probably from the main files), but any alterations to those files keeps a copy of the altered file somewhere else that must be accessed when the module is reloaded. i.e. The main campaign files from the install directory remain unaffected, but the copied loaded module version maintains the edited version. NB: The copied module (where I saved the campaign script alteration), remains unaltered! (i.e. The campaign script was NOT saved along with the module.)

So, where does the saved campaign script version go to?

I really have no clue as to what’s going on, but when you said:

Maybe that’s why everything is screwed up. I mean, NWN2 and the Toolset can go bonkers for less and behave erratically. What happens if you remove the content of the copied campaign folders and module files from MyDocuments? Have you tried that?

Did you check in the campaign directory of the installation folder ?


As I say, it is completely unchanged …


If I did that, how would I open the files for viewing? (I mean, I do not want to open and edit the toolset versions.)

Also, out of interest, I wondered what would happen if I tried to add a campaign script (called k_mod_hb_qzxsquingey) and I got this error message …


Which implies to me that it’s not doing any normal saving at this point …

Here is a text search from the toolset directory … No modifications …

And no modifications recorded anywhere here …

The property of the directory, “read only” and so on.


I would have said that as well, EXCEPT … the reloaded module has the edited script. :exploding_head:

@Tsongo (and any others who may wish to test this) …

To duplicate/test the issue, you can do this (if you have the time):

  1. Copy the MotB A_X1.mod to your own modules folder.
  2. Open it in the toolset.
  3. Edit the k_mod_hb campaign script by adding a comment. (There is no module script of this.)
  4. Use just the Save and Compile (assuming you have the Powerbar plugin button).
  5. Close the toolset.
  6. Reopen the toolset, load the file and the edit remains intact.

NOW, try to locate where that k_mod_hb file has been saved on your computer. None of the files I can locate have changed in any way. (Not even the copied across A_X1.mod from which the script was located.)

If anyone else can find it, that will be helpful. :+1:

script maybe in the toolset GUI but not saved on the drive.

Closed and reopened the toolset ?

Yes, save the campaign script, close the toolset completely, so all memory is cleared. But, when we open the toolset again and reopen the campaign script we edited last time, the campaign script has kept the edits.

Therefore, the campaign script we have edited must surely be saved somewhere on our hard-drives for the toolset to reload the campaign script from somewhere.

I cannot locate this edited campaign script file (k_mod_hb) in any folder.

Time to load some develloper kit.

Notepad++ or ultraedit or something like that, put a unique line in the script you want to find, save it,

and scan all content of the files inside the doc and install folder of NWN2 with ultraedit or Notepad++ or whatever little tool you use.


Well, I did something like this on two posts above (see screenshots), where I had TextCrawler scan both the installation and document folders where the file might be, and the results showed no modified files.

So, unless the edited campaign files have been placed somewhere else on the hard-drive, then I am at a loss.

I did start a whole computer search, but it was taking forever just to count up the files it was going to scan. So unless someone has some knowledge of where the files may also be being stored, then it still appears elusive.

I am trying TextCrawler with this now … “Where does my file go?”

UPDATE: TextCrawler did not find this phrase within: C:\Users\lance\Documents\Neverwinter Nights 2

To all …

I have now tested this on two computers and the same thing happens …

The saved campaign script (of a copied official module into our module directory) keeps the saved data for when we reopen the module and check the edited file, but the edited file cannot be found on the computer in any of the normal NWN2 repository locations.

The gauntlet has been thrown down … Where is this file located?

search in the installation directory then


All searched … Nothing!

EDIT: Done all installation, campaign and documents! Nothing!

I have something … Something called VirtualStore in my users directory … Investigating.