White Artifacts (no textures) in LoW's Mirkwood

Hail and well met, I was wondering if any of the oldbears here have come across this white artifacts, or lack of textures, in LoW’s tileset Mirkwood 1.6. It seems to occur with the sea cliffs feature, though it may be present in other tilesets. Thinking that maybe I had something in my hak order fouling it up, I tried it in a blank EE module with no haks except for the Mirkwood one. Same result. I was also curious if it was an EE thing. See below:

i’ll take a look at mine which i downloaded about… a month ago for the arbor falls module, i dont recall it ever having that feature. Ill get back with you on that though.

Well, I ruled out EE being the issue. I installed it in a clean 1.69 module and received the same results shown above. I also redownloaded the hak in case I had some corrupted files, but no change. I’m thinking either it’s a videocard/driver issue (but drivers are up to date), or something with the hak itself.

Late edit: It looks like there were some mislabeled textures in the hak. Symantric posted a fix here back in 2015. That seems to have resolved the issue, although I’m still seeing one texture missing/mislabeled, and that’s the water leaking out of the side of a sea cliff. Any ideas?

See below:

well if youre stull missing some textures im going to guess that those too are mislabeled, but thats justa possibility. At this point i think you may be answering your own questions and may have to troubleshoot it

Right. My point is that if these textures are mislabled for me, chances are they are mislabeled for everyone. And since I have no idea what I am looking at, I don’t the difference between something labeled right and something labeled wrong. I figured that this was hardly a new bug, and that someone had already figured it out (which they did but the answer is an unlikely location). Thus the point in posting the query.

You could always take a look at and maybe try a little utility that I wrote ages ago. It’s called Orphan Hunter and is one of a number of little utilities that I wrote ages ago.


So if you look at your screenshots, on the bottom left corner it actually spells out the name of the tile you are mousing over. Mouse over the tile with the white texture to get the name. Open the mdl in a notepad program like notepad++ and then search for “bitmap” bitmap should be in there a few times with the name of the texture files in use for each mesh in the mdl file written next to it. Just make sure they match the stuff in the hak or the stuff in stock nwn. If you don’t see the stuff it points to in the hak then you’ll know what needs renamed or replaced.

I see. Thank you so much for your reply. The deeper I get into this, the more I am discovering about this game, even after all of these years, I still know relatively little.

So, in examining the offending tile, it is the wmx01_v02_v03 (in the Castle Rural tileset, this corresponds to the tno01_v02_03 ). Opening that mdl file in Notepad, I can then go through the various bitmap references that I assume are the TGA files located in the hak itself or in the core game.

Everything I look at seems to match up with what is in the hak, or it references one of the TNO textures (which I am not sure where to find those). I can only assume the TNO references are correct, but it is possible that it is pointing to a wrong one.

However, one of the textures listed in the mdl that is not in the Mirkwood hak is wmx01_pt_grass01. Perhaps this is mislabeled? Or is missing? Or worse, never created? Or, supposed to reference a TNO feature but is erroneously pointing to a Worm texture?

To refresh, it is the water feature found here (below) in the TNO tileset:

That little water feature is missing from LoW’s Mirkwook 1.6 Tileset (unless there was a 1.7 that corrected this but I am not seeing one): see below

But also, the plot gets mirkens (sorry), for it is also the same texture/animation missing from the Chasm feature of the Mirkwood tileset, which is seen here:

As with the sea cliff variant, it also appears to be mislabeled or missing the wmx01_pt_grass01. My guess is that it should be referencing whatever that TNO texture is, but what is it exactly? or where might I find it in the 785 folder of EE these days? Or, I am completely off base and someone here might set me straight?

You could make it a little easier by downloading the “Bioware Standard Assets” which shows all the standard 1.69 materials.


Thanks Master Redhand. I dived into that headfirst. I tried a number of combinations, poured through the mdl files, referenced various tga’s , tried many combos that I thought it could be, or should be, imported, exported, loaded, reloaded – but alas! I am no closer to the truth than when I started. After two days of struggle, I am ready to concede defeat and move on. Tis ashame, too. But there are other battles to be fought, and I cannot linger long over so small a defeat lest I lose this war altogether.