White Space Around Interior Areas?

Lance was kind enough to assist with the Unofficial Patch I’m working on and pointed out something odd.

In Last of the Dana’an, interior areas are surrounded by a white space. In every other mod I checked, unbuilt areas are uniformly dark which appears to be the default program behavior.

None of the Area setting check boxes seem to affect this.

Any ideas?

Is the module overriding the black texture?

It looks like the author changed the area’s Day/Night Cycle Stages properties. Specifically, the FogColor setting. At night it’s a dark purple. Daytime is an off-white. It looks like he set all of the non-cave interior areas like that. I wonder if he intentionally did that to simulate the outside through the windows?

1 Like

What is the daytime default?

Open an area in any other module click the area name in the area window, open properties, look for day night cycle stages you’ll have sunrise, daytime, sunset etc. and open the drop down bit for default. Then you’ll see fog and that has the fog information like colour etc.

To get rid of the need for fiddling about in the properties window at the top you can export things, select export, then day night cycle stage, then default and export it. Open the module and area you want to change and do the reverse, select import, day night cycle stage, default and import the one you exported. You can do this for all areas using the same default setting you exported and then they’ll all be back to normal.

1 Like


I have PM you the solution. :slight_smile:

It is due to Day/Night cycles and your default day/night (7) choice of colours. EDIT: Using BLACK (EG: Sky Horizon and Sky Zenith, but consider others too like fog) would achieve your TRUE dark on interiors as your module info says it uses as well.

You need to ensure the DEFAULT (7) is all set to BLACK and then ensure the Day/Night cycles is set to FALSE. < This ensures there is no alteration due to time. Some builders may use “Always Night” setting to give a close to dark, but even that has some “light”. That’s why it is good to use a total BLACK DEFAULT and switch any light time cycling off.

If your settings have been altered too much and you are struggling to get them back, do as @Tsongo says and just import the default ones again. That may be the easiest solution, as iirc, that also allows you to keep other properties without losing the black surround regardless.

1 Like

Got it, thanks everyone.

1 Like

Lance_Botelle… I don’t want to be controversial but always night gives you a really big moon that’s why I use it and I think all interiors use the default settings regardless of what the day night cycle is because that’s the one I adjust for interiors and I never touch the day night cycle bit.

I also crank up the sky light for the daytime when doing interiors so you can see what you’re doing on tile sets like crypts etc. that are dark.

1 Like


That’s what I was alluding to with the “always night” option. :slight_smile:

That’s also why I said to alter the DEFAULT (7) setting. However, an interior will use the day/night cycle property option as I have a widget that cycles time along one hour, and interiors with these cycle settings do change depending upon the hour. However, I cannot say if that specifically refers back to the actual cycles (for interiors) - all I can say is that the day/night cycle property does make a difference to interiors and is why I turn it to FALSE if there is no chance of daylight affecting an area.

CAVES = FALSE. (No chance of daylight influence.)
BOAT HOUSE = TRUE. (Because daylight does penetrate the interior area.)

That’s exactly what I do too. However, you may also notice that you can also affect this using the Has Directional Light, which is why I also use that as FALSE for true darkness - and only have it on when building.

1 Like

I think directional light affects shadows too if you have too many point lights especially with water. I’m with you and normally have it off and I turn up the sky light to compensate. But turning it off can make characters faces a sort of flat colour.

Maybe time stops in interiors without a widget ! This is ground breaking science, NWN2 can freeze time and you are the widget creator, the manipulator of time !

1 Like


Unfortunately, stopping time is a whole other ball game. I have certainly looked into it when I worked on a true TB combat system. The fact that I compromised to end up with a pseudo TB system should tell you I failed to stop it as well as I would have liked. :wink: