Windows 10 /override and /hak folder location?

Toolset creates folders indeed but it’s empty and it doesn’t solve the problem…
I have 3 nwn copies, the gog one was the first time I tried but 2 others copy I had since a long moment and it worked until recently. I suppose it can be some recent update of windows which is responsible… but don’t know for sure.
As for permission I checked to run all shortcuts as administrator and give permission to all users.
The game is installed on D drive (never had a problem with that before and I don’t have problems with all the other games. I have the NWN1 gog too, without issues).

i wonder what happens if you open the toolset

copy a blueprint to global

it should appear in your MyDocs/nwn2/Override folder …

1 Like

Just to confirm, you’re checking in:

C:\Users\user\Documents

Correct? Or are you still using a shortcut for the -home switch?

1 Like

The way to my documents folder is passing by one drive cloud but yes… all the other game’s directories are here as well as nwn1. And nwn2 folder created by toolset is here too but completely empty. I will post the screen here later when I will have access to my pc (I’m on my phone and not at home right now).

It worked before on my windows 10 too, but last time I played was 3 years ago (same laptop). Now it doesn’t, I have the very last update version of windows 10. While in game when I’m trying to save the game it says the game is successfully saved but no saves created (in game too, each time I save there’s only empty slot for saving… nothing lasts). The nwn.ini does not exist. Nothing inside the folders created after running toolset… I will try to make some screens tomorrow when I’m at home.

1 Like

I don’t know how that works. Are you storing the folder in the cloud somehow? To me it seems that this would be the problem since NWN2 is such an old game and probably wasn’t made with that in mind. But, if you say it worked 3 years ago it seems really odd that it doesn’t work now, but perhaps it could be due to windows updates. I feel like you never know what Microsoft is up to and forces your computer to do.

Edit: Ok, I read about it and I guess you have it setup something like described here:


I’m such an old school guy I haven’t began to use cloud storage that much. My guess is if the folder only exists in the cloud for you that could maybe be a problem with an old game like NWN2.

2 Likes

Yes that’s it. I didn’t choose it tho, it was like that when I bought my laptop with windows 10 already integrated. But you see I have a lot of old games (like nwn1, baldur’s gate etc) and everything is ok. And nwn2 was working before. I will try to find out my last version of nwn2 on CD (without SoZ) and try to install this one…

1 Like

Well, apparently there is another problem with gog version… The MoW extension doesn’t work because “the dialogue file” does not exist… and I can’t check for a problem issues through the gog client because it can’t found the way to the folder where the game is located… wtf really.
I did uninstall the gog nwn2 for a moment. I will try to see if my repack works better (I will download a new one I think).

UPD!!!
Good news I found a solution. I installed a repack version on C drive, created a shortcut for the nwnmain.exe and used -home to redirect saves to the D drive. And it finally worked and even restored the MoW module lol. Maybe the main problem comes from the path to C drive’s folders after all… Tho I still can’t change the resolution in game (the screen just become black and I’m forced to cut out the PC because I can’t switch to the desktop or another window) but it worked when I changed inside the newly created .ini :slight_smile: I hope it remains as it.
Thank you all for the help!

2 Likes

Yep, that one is quite tricky with Windows 10.
Here’s how I got it working:

  • in your NWN2.ini file (the version in C:\Users<username>\Documents\Neverwinter Nights 2), within the [Display Options] section, put the resolution you want:
    Width=3240 (or whatever your display is capable of)
    Height=2160 (or whatever your display is capable of)

  • it’s been a while, but I believe I also had to specify the display settings (right-click on the .exe shortcut, go to the compatibility tab, modify PPP settings, tick the “replace the behavior. Scaling performed by” and select application in the drop-down list).
    The text will probably be different, my Win 10 is in French.

3 Likes

Yes, like I said below, the .ini changes were enough (I don’t have the same way to nwn2 folder, I redirected it with -home to D drive) . I had the French default too and after reinitialisarion it made russian (maybe because most of my apps are in russian… don’t know how it choose lol) but I quickly switched it to English, in windows 10 you can change the system language anytime you wish to. :slight_smile: Tho maybe the cyrillic/latin caused some issues with path to my documents folder. I figured out with onedrive there are 3 different ways to get to documents folder… I really didn’t get how it works and if it is possible under windows 10 to delete the onedrive cloud. I don’t think so.

1 Like

this strikes me as a distinct possibility. Nwn2 didn’t seem to get Unicode quite right …

1 Like

@ahopa So, does it work now for you or do you still have a black screen? I remember that issue with my laptop too, though I don’t know if I solved it the way 4760 did. If I remember correctly I had to start NWN2 in window mode, change the resolution there and then change it to fullscreen. But I could be wrong. I remember reading the solution on the gog forums though.

Edit: Sorry, I read too fast. I see now that you resolved the black screen when I read your post again.

It works with the nwn.ini modification (like he said). No other manipulations is requested for me. I have 2 graphic cards: integrated and Nvidia 1050.

1 Like

OK. Great to hear everything worked out in the end then!

1 Like

The thing is, the documents folder is written in English. But one of the paths have the word “documents” in russian and 2 others in English… truly, I’m lost. My ways to document folder:
C:\Users\name\OneDrive\Документы
Documents
C:\Users\name\Documents
The first one is in shortcut. So it must be that… probably. Tho before the reset of windows I did yesterday it was in English as much as I remember. And nwn2 didn’t work anyway.

3 Likes

Yes I put 3 days to make it work and I did the windows reset x) thank you for your concern and help :slight_smile:

3 Likes