Won't Freakin Run in Linux, Multiple Distros

Not exactly a cheap game and it won’t load any menus on linux. Nothing. Does nothing. I’ve tried OpenSuse, Manjaro, and Fedora at this point. Hardware is more than sufficient at 32 gb of ram, ATI RX580, and a Ryzen 3600…what the hell is the deal? I can’t even get it to run in Wine.

Are you posting in regards to NWN or NWN:EE? If its the EE version, have you looked over the Beamdog forums for topics covering running under Linux?

Try what is supposed to be the most popular distro - Ubuntu. I think EE for Linux was made with that distro in mind.


1 Like

I run both versions and in wine on opensuse. Works fine. I obviously can’t tell what’s wrong with your situation from the infotmation you provided. But I did find that an nvidia card with the prooprietary driver works best. I think I’ve done it on fedora 29 as well.

If you are starting non-EE it from the commandline there should be some indication as to what went wrong.I believe you need to setup an LD_LIBRARY_PATH to load one of the libraries that comes with the game. something like this in a wrapper script :

    cd  <path to nwn>
    export LD_LIBRARY_PATH=<path-to-nwn>/miles:$LD_LIBRARY_PATH 
    export SDL_VIDEO_X11_DGAMOUSE=0
    ./nwmain $@

This is only for the non EE linux version. If you are using EE then you can ignore this :slight_smile:

If you are on EE then you can still try to start it from the commandline and you may see something.
For beamdog for example on my system from a remote ssh session so I don’t expect it to work:

prompt> cd /data/space/beamdog_lib/00839/bin/linux-x86
prompt> ./nwmain-linux
Registering crash signal handlers.
Failed to initialize SDL Video: No available video device

I’m not sure about steam.

./nwmain-linux: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory

Created a symlink to the libopenal.so bin and then

./nwmain-linux: error while loading shared libraries: libopenal.so.1: cannot open shared object file: No such file or directory

which definitely exists in /usr/local/lib. Made sure this was on my path, which it would be assumed to be since the message changed yet no go.

Talking about EE for the relevance.

Are you using a 64bit os? I think the retail version of the game is still 32bit. You may need to install the 32bit libraries.

run ldd nwmain-linux
It will show all the libraries it needs and if they are found or not.

For example on my 64bit opensuse I have to have among others:

Retail is 32 bit for now. That will change when the dev branch is released into a retail patch.


That was it. pacman -Syu lib32-openal resolved the issue.