YET ANOTHER EE bug ?!

i ruined my evening… er… ‘tried to install nwn:ee’ again, after my first distasteful experiences a couple of years back. i heard they’d fixed things. apparently not.

what i wanted to do seemed simple enough : have the various supporting files stored in the game’s install root rather than infiltrating my documents. i moved the folders from my documents into the game install root, modified nwn.ini [still in my documents] changing all of the path entries to point to where i’d installed the game, and fired it up again – no joy, nwn just re-created all of the folders i’d just moved. i then copied the modified nwn.ini from my documents into the install root. same result. i then verified that the paths i’d put into nwn.ini really do exist, that i hadn’t made a type-o somewhere along the way. it’s all fine.

what am i missing ?

ready to eat raw crow, feathers and all, if this is just my stupidity. any help appreciated.

cheers

ps- this release is labeled as version 86.8193.34.1(a)   [hmm… i wonder why they didn’t just throw in any 5’s or 7’s too while they were at it… :thinking: ].
d/l’d from gog.

You can add a -userdirectory \some\path\here to your nwmain.exe shortcut to set the user folder. You’ll have to do the same for the toolset exe. I’d just keep the userdata in my documents where stuff like that belongs, tho.

1 Like

AFAIK, they’re split like that so that patches (whenever/if) don’t trash/delete the user made content that you have got.

TR

1 Like

Try putting the NWN user folders anywhere except the installation folders. Keep nwn.ini in Documents, but change all the paths in it to your new location. I have read, for example, that some people have continued to use c:\Neverwinter Nights\nwn for this purpose, to avoid the need for migration, while others have used a different disc, to conserve precious c: space.

What I can say for sure is that installing a new release will utterly destroy any user documents in the installation folders, as Tarot implied.

1 Like

Oh boy. Caps, the word combination of EE + bug, in title on top of it, words like “distasteful experiences” in conjunction with EE. Holy moly, do you want to end up outcast like me or what? :smiley:

This is forbidden you know, everything is perfect about EE, be grateful they even bothered to put any work on our beloved game. And stop complaining, thousands of players had no issues with EE so it must be error between table and chair. :wink:

To your issue - the installation folder of NWN-EE is “protected”, any new update will delete all extraneous files you put there (for example my community patch) so even if you make it work via changing paths in nwn.ini, such setup is not recommended. //Beamdog version, it seems that steam doesn’t do it, no idea about GOG but be wary.

I also hate this user/install folder bussiness, so what I do is that I still have diamond edition with the original path and I directed NWN-EE to those paths, mostly. Some of the paths should not be changed though like HD0= I think which can be reason it is not working for you. So if you want to avoid the folder in documents completely, you need to redirect it via -userdirectory parameter in nwn shortcuts, just don’t forget to update all paths int the nwn.ini to match this new paths.

Also note that you absolutely mustn’t use Surazal’s Installer Tool if you have this kind of setup. It will mess your folders and deletes files when you use it. (Or something like that, it is long time ago when I tried it, but it fked up my nwn completely)

4 Likes

many thanks to all of you for your words of wisdom. :slight_smile:
that’s given me enough grist to find a workaround.
cheers

I Liked your reply for the snark as well as the advice! :wink:

Hi Xorbaxian it’s Dustin.

I’m also interested in this issue for a different reason, perhaps. My system has a small SSD & larger HDD for “all the games.” The Steam install for NWN:EE can be convinced to put the bulk of the files on the HDD, but once you run it, the …\Documents\Neverwinter Nights folder is created. Once that starts to fill up with community content like modules, hak packs, etc., that SSD is not going to be sufficient for long.

My solution was fairly straight-forward. I move the folder “Neverwinter Nights” from the Documents folder on the SSD and to the HDD. Then I created a shortcut to it that I moved back into the Documents folder. Then I changed the sortcut’s name from “Neverwinter Nights - shortcut” to just “Neverwinter Nights” matching what EE expects.

No problems so far, though I just set this up recently so caveat emptor, YMMV, etc.

1 Like

Why not just move the entire /Documents, /Music, /Pictures, and other User Account folders to the HDD like I did? Keeps the SSD pretty compact.

1 Like

True enough! I’d not really considered it since this is specifically a system I refurbed for casual/low-resource-spec gaming. So there’s really nothing else in those other folders under \Documents.

In chagrin, I realize now that my approach does not work because NWN:EE just recreates the \Documents\Neverwinter Nights folder if it does not find it. It is not “tricked” into using the shortcut.

Windows also seems pretty resistant to moving the Documents folder. I’d best leave it be and rethink this from the start. What’s straight-forward under Linux doesn’t always translate well to Windows.

As I posted earlier in the thread, you can use the -userdirectory C:\some\path commandline parameter to set the location of the userdirectory. You can either set it in Steam using launch options or make your own nwmain.exe shortcut somewhere.

1 Like

Ummm…I don’t use Linux. I’m a Windows user. If you’re Win 10 or 11, moving the User folders is easy. Might be more difficult on earlier versions of Windows.

First, create a folder named /Documents on your HDD.

Right-click the /Documents folder on your SSD and select the Properties options. Click the Location tab. Click the Move button. Select the /Documents folder on the HDD.

Repeat for the other User folders if desired. I moved the /Music, /Pictures, /Videos, and /Downloads folders to my HDD as well.

2 Likes

Thanks, this would be a good general solution for everything that would mean no need for command line arguments to be set up, perhaps for other games as well. I’ll also try out what @Daz does. Now when I am first setting up this system is the best time to experiment.

Can I tell you an operating systems joke? Of course I can.

  • MacOS says, “We’re going to help you,” and mostly succeeds.
  • Windows says, “We’re going to help you,” and mostly gets in your way.
  • Linux says, “We trust you know what you’re doing. Here’s your rope. Have fun!”

Executive Summary: This is rather long, but I went with the suggestion of @Pstemarie as it ended up being the simplest.

Read on if the paint has finally dried and you’ve not yet found anything else to do. :wink:

I tried the solutions offered by both @Pstemarie and @Daz and they worked for me, but with caveats that are both unexpected (by me) behavior from Windows AND NWN EE having something to say about the name of the folder it’s willing to use for your local data.

What I did initially to move just EE’s Neverwinter folder from C:…\Documents (SSD) was to drag it to the D: drive (HDD) create a shortcut there and drop that shortcut back into the c:…\Documents directory. No joy.

The instructions from @Pstemarie indicated that I had to move the Documents folder from it’s Properties context menu, tab Location. No problem.

When I tried the same thing with a Neverwinter folder created by EE, it does not have a Location tab on it’s Properties panel.

I did not try to determine if that was a Windows feature or something EE configured.

I also tried the instructions from @Daz and discovered that EE was pretty “controlling” about what folder name it would accept in the -userdirectory parameter, variously modifying it or just replacing it with a “Neverwinter” folder. There may be a pattern to this, but I didn’t find it.

Further, I’m using GOG Galaxy, not the Steam client. (GOG gives you a copy of Diamond if you get EE from them.) The shortcut set up as proposed by @Daz worked as expected except for the folder naming stuff.

To do the same thing in GOG Galaxy:

  1. Go into the installed games page of the Galaxy client (this assumes you have already used Galaxy to install the game itself where you want it. No problem there.)
  2. Click the control panel (slider controls icon) to the right of the “Play Button”
  3. Go to Manage Installation > Configure…
  4. Click the Features tab
  5. Scroll down to the bottom, click “Add another executable / argument” or Duplicate a working one
  6. Edit executable and parameters to taste, click the radio button to make that the default executable and click OK.

So with all these interactions between OS, application and installer/launcher, I’m going with the simple solution proposed by @Pstemarie Except, of course, wouldn’t it be nice if the executables & base files were on the SSD for performance and…

Hmm. Maybe I should play the game for a bit before I forget why I went through all this in the first place.

Thanks to all for the assist!

Dustin

It’s actually pretty straightforward to put the EE base game on the SSD and the local data on the HDD.

  1. Use the technique of @Pstmarie to move the Documents folder to the HDD.
  2. Create a folder under your user directory for the installation directory to be passed to GOG Galaxy. In my case, it is C:\Users\Dustin Offal\NWNEEexecutable.
  3. Install EE to that directory using Galaxy.
  4. Run the game for the first time & it creates the local data Neverwinter folder in D:\ … \Documents.

The base game is now on the SSD & all the local data is on the HDD.

1 Like